Can't install a Redmine plugin

Keywords: Redmine - AWS - Technical issue - Plugins installation/configuration

bndiagnostic ID: 904dec6c-6eb1-6bfc-947c-a76ffa6aec38

bndiagnostic output:

? Resources: Found possible issues

bndiagnostic failure reason: The suggested guides are not related with my issue

I’m trying to install RedmineUp CRM plugin to a new clean Bitnami Redmine installed with Bitnami launchpad.
The Redmine version is 4.2.3-38
The CRM plugin version is 4.3.4
When I run bundle install --without development test RAILS_ENV=production as explained in the plugin README.doc, I get the following:

[DEPRECATED] The `--without` flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use `bundle config set --local without 'development test RAILS_ENV=production'`, and stop using this flag
You are trying to install in deployment mode after changing
your Gemfile. Run `bundle install` elsewhere and add the
updated Gemfile.lock to version control.

If this is a development machine, remove the /opt/bitnami/redmine/Gemfile freeze
by running `bundle config unset deployment`.

The dependencies in your gemfile changed

You have added to the Gemfile:
* redmine_crm
* vcard
* spreadsheet

Thank you for helping

Hi @simon.delmotte,

It seems you need to run these commands now

bundle config set --local without 'development test' RAILS_ENV=production
bundle install RAILS_ENV=production

Can you try to run them?

Hi Jota,

I get this message when I run

bundle config set --local without 'development test' RAILS_ENV=production
You are replacing the current local value of without, which is currently "development:test:RAILS_ENV=production:sqlite"

And this one one I run

bundle install RAILS_ENV=production
ERROR: "bundle install" was called with arguments ["RAILS_ENV=production"]
Usage: "bundle install [OPTIONS]"



I would like to add that the application is no longer accessible after launching the last commands.

Hi @simon.delmotte,

the last command returned an error and did nothing so that shouldn’t be the cause of the issue. However, the previous one modified a parameter. You can try to recover it by running this command

bundle config set --local without 'development test sqlite' RAILS_ENV=production

This just sets the list of gems to install but you installed nothing. Could you please contact the Redmine’s support team to know more about what’s happening in the application and how to install the plugin?


Hi Jota,
Here is the answer I got from the Redmine forum:

Bitnami is a third party tool for installing Redmine. Only the core Redmine is developed here. Please check there or ask for help:

Looks like I’m at an impasse.


Hi @simon.delmotte,

I just installed a plugin and didn’t have problems apart from some permission-related errors

The plugin I installed is this one

and I followed the bitnami guide

I understand you are running into a problem with the Redmine version you have and the plugin you are trying to install. The app’s developers should provide more info to debug their app but it seems they don’t want to. Could you please ask the plugin’s developer to know more about this?

Hi Jota,

I’ve finally managed to install the plugin:

I first ran

bundle config unset deployment

I then changed the database.yml configuration file to remove any reference to postgresql because I had an error installing pg 1.2.3:

Installing pg 1.2.3 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

I was then able to run the 2 commands to install the plugin:

bundle install
bundle exec rake redmine:plugins NAME=PLUGIN_NAME RAILS_ENV=production

Could you please confirme that it is ok to use

bundle config unset deployment

I mean, we are considering using this install for our business and I don’t want to have made a big mistake.


Hi @simon.delmotte,

that bundle config command will allow the application to modify the Gemfile and the dependencies that are currently installed

If this is a development machine, remove the /opt/bitnami/redmine/Gemfile freeze
by running `bundle config unset deployment`.

You should not do this in a production machine because it can break the deployment but if you already did that and confirmed that everything is working as expected, there shouldn’t be any problem.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.