Can't connect to mariadb database from diffrent machine

Keywords: MariaDB - Google Cloud Platform - Technical issue - Connectivity (SSH/FTP)
bnsupport ID: 2f95d3b3-40f4-3360-aa74-7084ff097d91
According to manual :

I commented bind address #bind-address=
and then i used this command:
/opt/bitnami/mysql/bin/mysql -u root -p -e “grant all privileges on . to ‘root’@’%’ identified by ‘PASSWORD’ with grant option”;

This is what i have got:
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

while trying to connect from diffrent machine i have Error (10060)

Can you please help me find fix for this?


Hi @mani103085,

Thanks for using Bitnami. The most recent versions of our stacks run MariaDB database instead of MySQL, and the filesystem paths are a bit different. Can you run the next command instead and then continue with the rest of steps in the guide?

/opt/bitnami/mariadb/bin/mysql -u root -p -e "grant all privileges on *.* to 'root'@'%' identified by 'PASSWORD' with grant option";

Hi it works perfect,

Thank you so much :smiley:

Hi @mani103085,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.