Can't access phpmyadmin and don't know solve the diagnose issues

Keywords: WordPress - Google Cloud Platform - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: 264b172a-ec64-bcd4-888a-ff8a7cf79fad

bndiagnostic output:

? Php: Found possible issues
? Apache: Found possible issues
https://docs.bitnami.com/general/apps/akeneo/administration/increase-memory-limit/
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
I want to access phpmyadmin. So i’m using nano /opt/bitnami/apps/phpmyadmin/conf/httpd-app.conf. but it shows Directory ‘/opt/bitnami/apps/phpmyadmin/conf’ does not exist

[Tue Nov 16 13:38:23.850996 2021] [proxy_fcgi:error] [pid 1243:tid 
140117034133248] [client **ip_address**:25178] AH01071: Got error 'PHP message: 
PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit 
change max_input_vars in php.ini. in Unknown on line 0', referer: 
https://vivishopee.com/wp-admin/nav-menus.php
 [Tue Nov 16 14:39:04.942850 2021] [proxy_fcgi:error] [pid 1243:tid 
140116689299200] [client **ip_address**:42386] AH01071: Got error 'PHP message: 
PHP Warning: strstr() expects parameter 1 to be string, object given in 
/opt/bitnami/wordpress/wp-includes/functions.php on line 1105PHP message: PHP 
Warning: stripos() expects parameter 1 to be string, object given in 
/opt/bitnami/wordpress/wp-includes/functions.php on line 1112PHP message: PHP 
Warning: stripos() expects parameter 1 to be string, objec [Tue Nov 16 
14:39:04.972999 2021] [proxy_fcgi:error] [pid 1243:tid 140116689299200] [client 
**ip_address**:42386] AH01071: Got error 'ter 1 to be string, object given in 
/opt/bitnami/wordpress/wp-includes/functions.php on line 1105PHP message: PHP 
Press [Enter] to continue:
Warning: stripos() expects parameter 1 to be string, object given in 
/opt/bitnami/wordpress/wp-includes/functions.php on line 1112PHP message: PHP 
Warning: stripos() expects parameter 1 to be string, object given in 
/opt/bitnami/wordpress/wp-includes/func

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/

===== End of bndiagnostic tool output =====

Press [Enter] to continue:
The files listed below are bigger than 10MB and have not been included, please notify the support agent.
/opt/bitnami/apache/logs/error_log
/opt/bitnami/apache2/logs/error_log
The diagnostic bundle was uploaded successfully to the Bitnami servers.

I’m beginner. So, i can’t understand the problem. please guide and help me for solve these problems.

Hi @shopeevivi173,

This seems to be a problem with the theme/extensions you have. You can try increasing the max_input_vars variable in the /opt/bitnami/php/etc/php.ini file.

This is another app-related error (it’s probably caused by the plugins/themes you have). We suggest you ask in the official forums of WordPress to get more information. However, you can also troubleshoot the issue by disabling all plugins and enabling them again one by one to know what’s the problematic one.

https://wordpress.org/support/

Thanks

1 Like

Thank you Sir,
I want to access phpmyadmin. So i’m using nano /opt/bitnami/apps/phpmyadmin/conf/httpd-app.conf. but it shows Directory ‘/opt/bitnami/apps/phpmyadmin/conf’ does not exist. how can i edit httpd-app.conf? nano /opt/bitnami/apps/phpmyadmin/conf/httpd-app.conf correct or not?

Hi @shopeevivi173,

Why do you want to edit that file? The new configuration file is at /opt/bitnami/apache/conf/bitnami/phpmyadmin.conf

1 Like

need to access phpmyadmin directly without help of ssh from youtube video tutorial. They asks need to change ‘allow from 127.0.01’ to ‘allow from all granted’. They using nano /opt/bitnami/apps/phpmyadmin/conf/httpd-app.conf but i have receive Directory ‘/opt/bitnami/apps/phpmyadmin/conf’ error. Thats why im asking. is this safe?

Hello @shopeevivi173,

For security reasons, we only enable access via 127.0.0.1. Even it is not recommended, you can enable remote access by accessing via SSH and editing /opt/bitnami/apache/conf/bitnami/phpmyadmin.conf and changing:

Require local

with

Require all granted

then, restart apache:

sudo /opt/bitnami/ctlscript.sh restart apache

Regards

1 Like

Ok sir. But i accessing phpmyadmin by using ssh tunnel.

Hi @shopeevivi173,

Here you said you want to access directly without using SSH. That’s why I explained the previous approach.

Regards