Cannot update geos component

Keywords: PostgreSQL - Google Cloud Platform - Technical issue - Upgrade
bnsupport ID: 76f2e1a4-d25b-9d82-be14-0751e15ecde9
Description:
When trying to run the configure command for postgis 2.4.5, I come across this alert:

configure: WARNING: --------- GEOS VERSION WARNING ------------
configure: WARNING: You are building against GEOS 3.5.1
configure: WARNING: To take advantage of all the features of
configure: WARNING: this PostGIS version requires GEOS 3.7.0 or higher.
configure: WARNING: To take advantage of most of the features of this PostGIS
configure: WARNING: we recommend GEOS 3.6 or higher
configure: WARNING: You can download the latest versions from
configure: WARNING: http://trac.osgeo.org/geos
configure: WARNING:

I tried installing geos 3.7 separately but it didn’t get picked up in the postgis configuration. How can I update the geos component that is part of the bitnami stack?

Hi @hlau,

We build the different components the stacks include from scratch. In this case, I verified that we are using GEOS 3.5.1 when building PostgreSQL. Using a new version of GEOS implies building PostgreSQL again and that’s not an easy task.

I’m going to open a new task in our board to update the GEOS version but we can’t provide you with an estimation about when this will be available. As this is just only a WARNING message, did you obtain any error message when continuing the process? Can you try a previous version of PostGIS?

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.