Cannot renew SSL

Keywords: WordPress + NGINX + SSL - Google Cloud Platform - Technical issue - Other
bnsupport ID: fda64552-2299-d54a-a4cd-85d003cccff9
Description:
I have problem with ssl certificate. Then I do something, now I can’t start Nginx.

/opt/bitnami/mysql/scripts/ctl.sh : mysql (pid 19218) already running
/opt/bitnami/php/scripts/ctl.sh : php-fpm (pid 19284) already running
nginx: [emerg] BIO_new_file("/opt/bitnami/nginx/conf/vietpublish.com.crt") failed (SSL: error:02001002:system libra
ry:fopen:No such file or directory:fopen(’/opt/bitnami/nginx/conf/vietpublish.com.crt’,‘r’) error:2006D080:BIO rout
ines:BIO_new_file:no such file)
/opt/bitnami/nginx/scripts/ctl.sh: 77: [: Illegal number:
/opt/bitnami/nginx/scripts/ctl.sh : Nginx could not be started

I fixed the problem above. But now I can’t renew ssl certificate.

Hi @nguyenhoaiminhh,

This file (/opt/bitnami/nginx/conf/vietpublish.com.crt) was missing and that’s why NGINX can’t be started. Could you please let us know what you did to solve that error message and what error message you are getting now? It’d be helpful if you run the Bitnami Support tool again

https://docs.bitnami.com/general/how-to/understand-bnsupport/

Thanks

Keywords: WordPress + NGINX + SSL - Google Cloud Platform - Technical issue - Secure Connections (SSL/HTTPS)
bnsupport ID: 4b3e3ada-07c9-4e81-b6be-e3a9a1511395
Description:
I have tried to download lego but I can’t use it .

lego_v2.3.0_linux_amd64.tar 100%[=========================================>] 8.17M 4.23MB/s in 1.9s
2019-03-21 09:41:21 (4.23 MB/s) - ‘lego_v2.3.0_linux_amd64.tar.gz.3’ saved [8569285/8569285]
FINISHED --2019-03-21 09:41:21–
Total wall clock time: 3.7s
Downloaded: 1 files, 8.2M in 1.9s (4.23 MB/s)
root@vietpublish-vm:/tmp# tar xf lego_v2.3.0_linux_amd64.tar.gz
root@vietpublish-vm:/tmp# sudo mv lego /opt/bitnami/letsencrypt/lego
mv: cannot move ‘lego’ to ‘/opt/bitnami/letsencrypt/lego’: No such file or directory

Hi @nguyenhoaiminhh,

It seems you have a lot of “lego” files in the /tmp folder. Can you create a new folder and try to download the lego binary again?

mkdir -p /tmp/download_lego
cd /tmp/download_lego
curl -Ls https://api.github.com/repos/xenolf/lego/releases/latest | grep browser_download_url | grep linux_amd64 | cut -d '"' -f 4 | wget -i -
tar xf lego_vX.Y.Z_linux_amd64.tar.gz
sudo mv lego /usr/local/bin/lego

Thanks

I have download lego again, but when I run sudo mv lego /usr/local/bin/lego, it’s still: root@vietpublish-vm:~# sudo mv lego /usr/local/bin/lego
mv: cannot stat ‘lego’: No such file or directory

I can’t start Nginx again.

nginx: [emerg] BIO_new_file("/opt/bitnami/nginx/conf/server.crt") failed (SSL: error:02001002:system library:fopen:
No such file or directory:fopen(’/opt/bitnami/nginx/conf/server.crt’,‘r’) error:2006D080:BIO routines:BIO_new_file:
no such file)

Hi @nguyenhoaiminhh,

Please run and share the entire output of these commands with us

mkdir -p /tmp/download_lego1
cd /tmp/download_lego1
curl -Ls https://api.github.com/repos/xenolf/lego/releases/latest | grep browser_download_url | grep linux_amd64 | cut -d '"' -f 4 | wget -i -
ls .
tar xf lego_v2.3.0_linux_amd64.tar.gz
ls .
sudo mv lego /usr/local/bin/lego
lego --version

Can you run the bnsupport tool again?

https://docs.bitnami.com/general/how-to/understand-bnsupport/

Apart from that, share with us the output of these commands

sudo ls -la /opt/bitnami/letsencrypt/certificates/
sudo ls -la /etc/lego/certificates/

Thanks

Hello,
I have just start a new deployment with WordPress with NGINX and SSL Certified by Bitnami.
How can I enable SSL on this ?

@nguyenhoaiminhh,

Can you take a look at this YouTube video? We explain how to generate a Let’s Encrypt certificate there:

https://www.youtube.com/watch?v=Ru0t9P-aP0I&list=PLGgVZHi3XQNm-dQwUU0K83kMKIdCILGy7

You can find more information about this in our documentation

https://docs.bitnami.com/google/apps/wordpress-pro/administration/generate-configure-certificate-letsencrypt/

Hey i was facing same error,but above code worked.Thank you so much.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.