Cannot login after Azure VM automated shutdown and re-start

Keywords: Alfresco - Microsoft Azure - Technical issue - Other
bnsupport ID: 1178dba1-e81e-d532-1d8e-035872eac088
Description:
hi guys,
i installed Alfresco Community on a linux VM in Azure the other day, it worked perfecly, i was able to access the share, admin portal, etc.
i created two multi-tenant records in Alfresco,
i also changed the Azure DNS name (but kept the original IP address)

to keep running costs down i shut down the server overnight with an automated shutdown, and re-start in the morning.

what i found however was day 2 i could not log in or access the admin portal

on the share login screen i get -->Your authentication details haven’t been recognized or Alfresco Content Services may not be available at this time.

on the admin portal i get --> http 404 The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

i suspect there is a problem with the database, but i’m very new to linux so i’m really only poking around and guessing.

any thoughts / assistance?

I have also located the error logs;

    [Sun Jul 19 00:00:08.411045 2020] [mpm_prefork:notice] [pid 1415] AH00171: Graceful restart requested, doing restart
[Sun Jul 19 00:00:08.443323 2020] [ssl:warn] [pid 1415] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 19 00:00:08.459791 2020] [mpm_prefork:notice] [pid 1415] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Sun Jul 19 00:00:08.459803 2020] [core:notice] [pid 1415] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Sun Jul 19 02:00:16.787859 2020] [pagespeed:error] [pid 4059] [mod_pagespeed 1.13.35.2-0 @4059] Slow ReadFile operation on file /opt/bitnami/apache2/var/cache/mod_pagespeed/v3/13.70.180.20/http,3A/,2F13.70.180.20/portal/redlion,: 121.493ms; configure SlowFileLatencyUs to change threshold\n
[Sun Jul 19 06:25:02.013397 2020] [pagespeed:error] [pid 4049] [mod_pagespeed 1.13.35.2-0 @4049] Slow ReadFile operation on file /opt/bitnami/apache2/var/cache/mod_pagespeed/v3/13.70.180.20/http,3A/,2F13.70.180.20/TP/index.php,: 245.665ms; configure SlowFileLatencyUs to change threshold\n
[Sun Jul 19 13:01:54.864445 2020] [mpm_prefork:notice] [pid 1415] AH00169: caught SIGTERM, shutting down
[Sun Jul 19 21:08:54.287207 2020] [ssl:warn] [pid 1674] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 19 21:08:54.341377 2020] [ssl:warn] [pid 1675] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 19 21:08:54.360816 2020] [mpm_prefork:notice] [pid 1675] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Sun Jul 19 21:08:54.360848 2020] [core:notice] [pid 1675] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Sun Jul 19 21:09:18.736512 2020] [proxy_ajp:error] [pid 1684] (104)Connection reset by peer: AH01030: ajp_ilink_receive() can't receive header
[Sun Jul 19 21:09:18.736580 2020] [proxy_ajp:error] [pid 1684] [client 127.0.0.1:36879] AH00992: ajp_read_header: ajp_ilink_receive failed
[Sun Jul 19 21:09:18.736590 2020] [proxy_ajp:error] [pid 1684] (120006)APR does not understand this error code: [client 127.0.0.1:36879] AH00878: read response failed from [::1]:8009 (localhost)
[Sun Jul 19 21:09:20.114086 2020] [proxy:error] [pid 1689] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Sun Jul 19 21:09:20.114132 2020] [proxy_ajp:error] [pid 1689] [client 127.0.0.1:60547] AH00896: failed to make connection to backend: localhost
[Sun Jul 19 21:09:20.123841 2020] [proxy:error] [pid 1687] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Sun Jul 19 21:09:20.123873 2020] [proxy_ajp:error] [pid 1687] [client 127.0.0.1:46797] AH00896: failed to make connection to backend: localhost
[Sun Jul 19 21:09:20.158428 2020] [proxy:error] [pid 1686] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Sun Jul 19 21:09:20.158465 2020] [proxy_ajp:error] [pid 1686] [client 127.0.0.1:52445] AH00896: failed to make connection to backend: localhost
[Sun Jul 19 21:09:30.008012 2020] [proxy:error] [pid 1685] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Sun Jul 19 21:09:30.008108 2020] [proxy_ajp:error] [pid 1685] [client 127.0.0.1:48721] AH00896: failed to make connection to backend: localhost
[Sun Jul 19 21:09:30.010495 2020] [proxy:error] [pid 1688] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Sun Jul 19 21:09:30.010526 2020] [proxy_ajp:error] [pid 1688] [client 127.0.0.1:42647] AH00896: failed to make connection to backend: localhost
[Sun Jul 19 21:09:30.094786 2020] [proxy:error] [pid 1681] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Sun Jul 19 21:09:30.094824 2020] [proxy_ajp:error] [pid 1681] [client 127.0.0.1:38503] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 01:58:36.627348 2020] [pagespeed:error] [pid 1687] [mod_pagespeed 1.13.35.2-0 @1687] Slow ReadFile operation on file /opt/bitnami/apache2/var/cache/mod_pagespeed/v3/13.70.180.20/http,3A/,2F13.70.180.20/hudson,: 279.863ms; configure SlowFileLatencyUs to change threshold\n
[Mon Jul 20 04:56:31.823717 2020] [mpm_prefork:notice] [pid 1675] AH00169: caught SIGTERM, shutting down
[Mon Jul 20 05:02:32.685457 2020] [ssl:warn] [pid 1615] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 05:02:32.802447 2020] [ssl:warn] [pid 1616] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 05:02:32.827391 2020] [mpm_prefork:notice] [pid 1616] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Mon Jul 20 05:02:32.827430 2020] [core:notice] [pid 1616] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Mon Jul 20 05:02:56.742738 2020] [proxy_ajp:error] [pid 1630] (104)Connection reset by peer: AH01030: ajp_ilink_receive() can't receive header
[Mon Jul 20 05:02:56.742748 2020] [proxy_ajp:error] [pid 1624] (104)Connection reset by peer: AH01030: ajp_ilink_receive() can't receive header
[Mon Jul 20 05:02:56.742800 2020] [proxy_ajp:error] [pid 1630] [client 127.0.0.1:38675] AH00992: ajp_read_header: ajp_ilink_receive failed
[Mon Jul 20 05:02:56.742804 2020] [proxy_ajp:error] [pid 1624] [client 127.0.0.1:33045] AH00992: ajp_read_header: ajp_ilink_receive failed
[Mon Jul 20 05:02:56.742811 2020] [proxy_ajp:error] [pid 1630] (120006)APR does not understand this error code: [client 127.0.0.1:38675] AH00878: read response failed from [::1]:8009 (localhost)
[Mon Jul 20 05:02:56.742814 2020] [proxy_ajp:error] [pid 1624] (120006)APR does not understand this error code: [client 127.0.0.1:33045] AH00878: read response failed from [::1]:8009 (localhost)
[Mon Jul 20 05:02:56.742997 2020] [proxy_ajp:error] [pid 1622] (104)Connection reset by peer: AH01030: ajp_ilink_receive() can't receive header
[Mon Jul 20 05:02:56.743069 2020] [proxy_ajp:error] [pid 1622] [client 127.0.0.1:49389] AH00992: ajp_read_header: ajp_ilink_receive failed
[Mon Jul 20 05:02:56.743078 2020] [proxy_ajp:error] [pid 1622] (120006)APR does not understand this error code: [client 127.0.0.1:49389] AH00878: read response failed from [::1]:8009 (localhost)
[Mon Jul 20 05:03:00.004974 2020] [proxy:error] [pid 1626] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 05:03:00.005041 2020] [proxy_ajp:error] [pid 1626] [client 127.0.0.1:59317] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 05:03:00.011847 2020] [proxy:error] [pid 1621] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 05:03:00.011880 2020] [proxy_ajp:error] [pid 1621] [client 127.0.0.1:42715] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 05:03:00.065485 2020] [proxy:error] [pid 1628] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 05:03:00.065546 2020] [proxy_ajp:error] [pid 1628] [client 127.0.0.1:39651] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 05:03:10.002795 2020] [proxy:error] [pid 1627] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 05:03:10.002854 2020] [proxy_ajp:error] [pid 1627] [client 127.0.0.1:35281] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 05:03:10.031954 2020] [proxy:error] [pid 1629] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 05:03:10.031988 2020] [proxy_ajp:error] [pid 1629] [client 127.0.0.1:46237] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 05:03:10.080526 2020] [proxy:error] [pid 1625] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 05:03:10.080577 2020] [proxy_ajp:error] [pid 1625] [client 127.0.0.1:52287] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 06:19:06.646371 2020] [mpm_prefork:notice] [pid 1616] AH00169: caught SIGTERM, shutting down
[Mon Jul 20 06:19:10.676397 2020] [ssl:warn] [pid 3411] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 06:19:10.712155 2020] [ssl:warn] [pid 3412] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 06:19:10.730446 2020] [mpm_prefork:notice] [pid 3412] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Mon Jul 20 06:19:10.730475 2020] [core:notice] [pid 3412] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Mon Jul 20 06:36:30.005378 2020] [proxy:error] [pid 3443] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 06:36:30.005445 2020] [proxy_ajp:error] [pid 3443] [client 127.0.0.1:60419] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 06:36:30.007886 2020] [proxy:error] [pid 3474] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 06:36:30.007923 2020] [proxy_ajp:error] [pid 3474] [client 127.0.0.1:37423] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 06:36:30.010736 2020] [proxy:error] [pid 3435] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 06:36:30.010776 2020] [proxy_ajp:error] [pid 3435] [client 127.0.0.1:38147] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 06:36:40.002075 2020] [proxy:error] [pid 3476] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 06:36:40.002179 2020] [proxy_ajp:error] [pid 3476] [client 127.0.0.1:48755] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 06:36:40.007161 2020] [proxy:error] [pid 3429] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 06:36:40.007199 2020] [proxy_ajp:error] [pid 3429] [client 127.0.0.1:50943] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 06:36:40.012612 2020] [proxy:error] [pid 3471] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 06:36:40.012650 2020] [proxy_ajp:error] [pid 3471] [client 127.0.0.1:41289] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 13:02:14.985934 2020] [mpm_prefork:notice] [pid 3412] AH00169: caught SIGTERM, shutting down
[Mon Jul 20 21:08:48.065710 2020] [ssl:warn] [pid 1674] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 21:08:48.142735 2020] [ssl:warn] [pid 1675] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 21:08:48.180806 2020] [mpm_prefork:notice] [pid 1675] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Mon Jul 20 21:08:48.180846 2020] [core:notice] [pid 1675] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Mon Jul 20 21:09:11.325582 2020] [proxy_ajp:error] [pid 1687] (104)Connection reset by peer: AH01030: ajp_ilink_receive() can't receive header
[Mon Jul 20 21:09:11.325701 2020] [proxy_ajp:error] [pid 1687] [client 127.0.0.1:40955] AH00992: ajp_read_header: ajp_ilink_receive failed
[Mon Jul 20 21:09:11.325723 2020] [proxy_ajp:error] [pid 1687] (120006)APR does not understand this error code: [client 127.0.0.1:40955] AH00878: read response failed from [::1]:8009 (localhost)
[Mon Jul 20 21:09:20.130754 2020] [proxy:error] [pid 1688] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 21:09:20.130794 2020] [proxy_ajp:error] [pid 1688] [client 127.0.0.1:58679] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 21:09:20.131859 2020] [proxy:error] [pid 1685] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 21:09:20.131915 2020] [proxy_ajp:error] [pid 1685] [client 127.0.0.1:60997] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 21:09:20.154199 2020] [proxy:error] [pid 1686] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 21:09:20.154232 2020] [proxy_ajp:error] [pid 1686] [client 127.0.0.1:41281] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:15:40.005217 2020] [proxy:error] [pid 1685] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:15:40.005248 2020] [proxy_ajp:error] [pid 1685] [client 127.0.0.1:50747] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:15:40.006609 2020] [proxy:error] [pid 1687] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:15:40.006628 2020] [proxy_ajp:error] [pid 1687] [client 127.0.0.1:46141] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:15:40.011130 2020] [proxy:error] [pid 1689] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:15:40.011183 2020] [proxy_ajp:error] [pid 1689] [client 127.0.0.1:32973] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:15:50.001603 2020] [proxy:error] [pid 3791] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:15:50.001683 2020] [proxy_ajp:error] [pid 3791] [client 127.0.0.1:42669] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:15:50.020445 2020] [proxy:error] [pid 1688] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:15:50.020467 2020] [proxy_ajp:error] [pid 1688] [client 127.0.0.1:38393] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:15:50.021339 2020] [proxy:error] [pid 1684] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:15:50.021390 2020] [proxy_ajp:error] [pid 1684] [client 127.0.0.1:51269] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:51:24.057122 2020] [mpm_prefork:notice] [pid 1675] AH00169: caught SIGTERM, shutting down
[Mon Jul 20 23:51:28.083634 2020] [ssl:warn] [pid 5100] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 23:51:28.121304 2020] [ssl:warn] [pid 5101] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 23:51:28.138138 2020] [mpm_prefork:notice] [pid 5101] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Mon Jul 20 23:51:28.138169 2020] [core:notice] [pid 5101] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Mon Jul 20 23:54:30.005191 2020] [proxy:error] [pid 5133] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:30.005231 2020] [proxy_ajp:error] [pid 5133] [client 127.0.0.1:55167] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:54:30.008119 2020] [proxy:error] [pid 5134] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:30.008178 2020] [proxy_ajp:error] [pid 5134] [client 127.0.0.1:55647] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:54:30.008879 2020] [proxy:error] [pid 5116] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:30.008911 2020] [proxy_ajp:error] [pid 5116] [client 127.0.0.1:52931] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:54:40.002273 2020] [proxy:error] [pid 5120] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:40.002321 2020] [proxy_ajp:error] [pid 5120] [client 127.0.0.1:53019] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:54:40.002698 2020] [proxy:error] [pid 5114] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:40.002726 2020] [proxy_ajp:error] [pid 5114] [client 127.0.0.1:37931] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:54:40.008079 2020] [proxy:error] [pid 5115] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:40.008105 2020] [proxy_ajp:error] [pid 5115] [client 127.0.0.1:48369] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:54:50.002269 2020] [proxy:error] [pid 5121] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:50.002314 2020] [proxy_ajp:error] [pid 5121] [client 127.0.0.1:52827] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:54:50.002415 2020] [proxy:error] [pid 5124] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:50.002442 2020] [proxy_ajp:error] [pid 5124] [client 127.0.0.1:58195] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:54:50.012418 2020] [proxy:error] [pid 5113] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Jul 20 23:54:50.012442 2020] [proxy_ajp:error] [pid 5113] [client 127.0.0.1:43069] AH00896: failed to make connection to backend: localhost
[Mon Jul 20 23:55:58.036853 2020] [mpm_prefork:notice] [pid 5101] AH00169: caught SIGTERM, shutting down
[Mon Jul 20 23:56:02.054440 2020] [ssl:warn] [pid 5446] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 23:56:02.090862 2020] [ssl:warn] [pid 5447] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jul 20 23:56:02.107459 2020] [mpm_prefork:notice] [pid 5447] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Mon Jul 20 23:56:02.107491 2020] [core:notice] [pid 5447] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Tue Jul 21 00:04:51.237175 2020] [mpm_prefork:notice] [pid 5447] AH00169: caught SIGTERM, shutting down
[Tue Jul 21 00:04:55.268444 2020] [ssl:warn] [pid 5816] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 21 00:04:55.303846 2020] [ssl:warn] [pid 5817] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 21 00:04:55.320954 2020] [mpm_prefork:notice] [pid 5817] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Tue Jul 21 00:04:55.320990 2020] [core:notice] [pid 5817] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Tue Jul 21 00:34:23.783643 2020] [mpm_prefork:notice] [pid 5817] AH00169: caught SIGTERM, shutting down
[Tue Jul 21 00:35:14.343481 2020] [ssl:warn] [pid 7639] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 21 00:35:14.382150 2020] [ssl:warn] [pid 7640] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 21 00:35:14.401189 2020] [mpm_prefork:notice] [pid 7640] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Tue Jul 21 00:35:14.401228 2020] [core:notice] [pid 7640] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Tue Jul 21 00:36:44.984855 2020] [mpm_prefork:notice] [pid 7640] AH00169: caught SIGTERM, shutting down
[Tue Jul 21 00:37:35.504342 2020] [ssl:warn] [pid 8555] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 21 00:37:35.548940 2020] [ssl:warn] [pid 8556] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 21 00:37:35.568533 2020] [mpm_prefork:notice] [pid 8556] AH00163: Apache/2.4.43 (Unix) OpenSSL/1.1.1g configured -- resuming normal operations
[Tue Jul 21 00:37:35.568564 2020] [core:notice] [pid 8556] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'

Additional steps so far,

i have removed the Azure DNS name, so i have that now back to only the IP address, re-started all services, no impact.,still cannot log in

followed the bitnami static IP instructions
https://docs.bitnami.com/azure/faq/configuration/configure-static-address/

followed the bitnami custom domain instructions
https://docs.bitnami.com/azure/faq/configuration/configure-custom-domain/

re-started all serices, no impact still cannot log in…

Hello @QC-Technology,

Could you try these commands a let us know if it helps?

sudo /opt/bitnami/apps/alfresco/bnconfig --userpassword NEW_PASSWORD
sudo /opt/bitnami/ctlscript.sh restart

change NEW_PASSWORD for the new desired password

Regards

no luck, interestingly though the restart command did spit out a connection exception;

bitnami@QCAlfresco:~$ sudo /opt/bitnami/ctlscript.sh restart
Syntax OK
/opt/bitnami/apache2/scripts/ctl.sh : httpd stopped
Using CATALINA_BASE:   /opt/bitnami/apache-tomcat
Using CATALINA_HOME:   /opt/bitnami/apache-tomcat
Using CATALINA_TMPDIR: /opt/bitnami/apache-tomcat/temp
Using JRE_HOME:        /opt/bitnami/java
Using CLASSPATH:       /opt/bitnami/apache-tomcat/bin/bootstrap.jar:/opt/bitnami/apache-tomcat/bin/tomcat-juli.jar
Using CATALINA_PID:    /opt/bitnami/apache-tomcat/temp/catalina.pid
NOTE: Picked up JDK_JAVA_OPTIONS:   --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED
Jul 21, 2020 10:32:42 PM org.apache.catalina.startup.Catalina stopServer
SEVERE: Could not contact [localhost:8005]. Tomcat may not be running.
Jul 21, 2020 10:32:42 PM org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:
java.net.ConnectException: Connection refused (Connection refused)
        at java.base/java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.base/java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:399)
        at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:242)
        at java.base/java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:224)
        at java.base/java.net.SocksSocketImpl.connect(SocksSocketImpl.java:403)
        at java.base/java.net.Socket.connect(Socket.java:609)
        at java.base/java.net.Socket.connect(Socket.java:558)
        at java.base/java.net.Socket.<init>(Socket.java:454)
        at java.base/java.net.Socket.<init>(Socket.java:231)
        at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:504)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:566)
        at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:389)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:479)

The stop command failed. Attempting to signal the process to stop through OS signal.
Tomcat stopped.
/opt/bitnami/apache-tomcat/scripts/ctl.sh : tomcat stopped
/opt/bitnami/apache-solr/scripts/ctl.sh : solr stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql  started at port 3306
/opt/bitnami/apache-solr/scripts/ctl.sh : solr started
Using CATALINA_BASE:   /opt/bitnami/apache-tomcat
Using CATALINA_HOME:   /opt/bitnami/apache-tomcat
Using CATALINA_TMPDIR: /opt/bitnami/apache-tomcat/temp
Using JRE_HOME:        /opt/bitnami/java
Using CLASSPATH:       /opt/bitnami/apache-tomcat/bin/bootstrap.jar:/opt/bitnami/apache-tomcat/bin/tomcat-juli.jar
Using CATALINA_PID:    /opt/bitnami/apache-tomcat/temp/catalina.pid
Tomcat started.
/opt/bitnami/apache-tomcat/scripts/ctl.sh : tomcat started
Syntax OK
/opt/bitnami/apache2/scripts/ctl.sh : httpd started at port 80
bitnami@QCAlfresco:~$

ahh the exception could have been due to a step of changing the bnconfig to bnconfig.disabled as per one of the steps for having a different app name…

i changed that back from bnconfig.disabled to bnconfig and re-started again.
looks a bit more normal… still getting the login issue and the admin page is still giving a 404
http:///alfresco/s/admin/

bitnami@QCAlfresco:~$ sudo /opt/bitnami/ctlscript.sh restart
Syntax OK
/opt/bitnami/apache2/scripts/ctl.sh : httpd stopped
Using CATALINA_BASE:   /opt/bitnami/apache-tomcat
Using CATALINA_HOME:   /opt/bitnami/apache-tomcat
Using CATALINA_TMPDIR: /opt/bitnami/apache-tomcat/temp
Using JRE_HOME:        /opt/bitnami/java
Using CLASSPATH:       /opt/bitnami/apache-tomcat/bin/bootstrap.jar:/opt/bitnami/apache-tomcat/bin/tomcat-juli.jar
Using CATALINA_PID:    /opt/bitnami/apache-tomcat/temp/catalina.pid
NOTE: Picked up JDK_JAVA_OPTIONS:   --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED
Tomcat did not stop in time.
To aid diagnostics a thread dump has been written to standard out.
Killing Tomcat with the PID: 5351
The Tomcat process has been killed.
/opt/bitnami/apache-tomcat/scripts/ctl.sh : tomcat stopped
/opt/bitnami/apache-solr/scripts/ctl.sh : solr stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql  started at port 3306
/opt/bitnami/apache-solr/scripts/ctl.sh : solr started
Using CATALINA_BASE:   /opt/bitnami/apache-tomcat
Using CATALINA_HOME:   /opt/bitnami/apache-tomcat
Using CATALINA_TMPDIR: /opt/bitnami/apache-tomcat/temp
Using JRE_HOME:        /opt/bitnami/java
Using CLASSPATH:       /opt/bitnami/apache-tomcat/bin/bootstrap.jar:/opt/bitnami/apache-tomcat/bin/tomcat-juli.jar
Using CATALINA_PID:    /opt/bitnami/apache-tomcat/temp/catalina.pid
Tomcat started.
/opt/bitnami/apache-tomcat/scripts/ctl.sh : tomcat started
Syntax OK
/opt/bitnami/apache2/scripts/ctl.sh : httpd started at port 80
bitnami@QCAlfresco:~$

Hi,

I was able to partially reproduce the issue. It seems that the bnconfig --machine_hostname command failed.

Could you show the output of this command?

sudo cat /opt/bitnami/apache-tomcat/shared/classes/alfresco-global.properties | grep host

Did you also execute bnconfig --appdomain at some point?

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

yes i tried to execute the --machine_hostname i was following this link https://docs.bitnami.com/azure/faq/configuration/configure-custom-domain/

i do not believe i have executed a bnconfig --appdomain command

results of the command below

alfresco.host=app.qc-docs.com
share.host=app.qc-docs.com
db.url=jdbc:mysql://localhost:3306/bitnami_alfresco?useUnicode=yes&characterEncoding=UTF-8&serverTimezone=UTC
solr.host=localhost
mail.host=smtp.mailgun.org

Hi,

Let’s try doing something in order to see if we are able to get to a working state (and then perform the necessary changes). Could you try changing the alfresco.host and share.host to the instance IP instead? That helped me to fix some connection issues.

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

okay so i have reverted to the IP with the machine_hostname

restarted and still cannot access… i must have done something really stupid :frowning:

at this stage i’m thinking a re-install will be faster and easier

 ties | grep host
alfresco.host=13.70.180.20
share.host=13.70.180.20
db.url=jdbc:mysql://localhost:3306/bitnami_alfresco?useUnicode=yes&characterEncoding=UTF-8&serverTimezone=UTC
solr.host=localhost
mail.host=smtp.mailgun.org

is there a way to see if the DB is actually connected? i can see it’s running not sure how to check if it’s connected or not

Hi,

You could try accessing it with the mysql client.

mysql -uroot 

You will be prompted for your password. Also, I agree that doing a fresh reinstall may be easier. I was able to access the instance with a domain name without using bnconfig --machine_hostname

okay so i called it yesterday and i deleted the VM and re-started.

i was able to get alfresco up and running, the only thing i added was the auto-shutdown

i confirmed the service was running a number of times through the day. i let the Azure auto shutdown and re-start occur. and exactly the same issue happened.

i cannot log into the service.

so i think there is a problem here with the Azure build.

i’m not going to try the Bitnami launchpad and see if i have a different result.

also on a related / un-realted topic, when i tried to put in a multi-tenant yesterday, i was able to create the records, but there was a big exception thrown which looks like a folder permissions issue.
if i hit that with the launchpad install, i’ll create a separate issue

Hi,

This is strange, I was unable to reproduce it. I restarted the instance and I could still access without problems.

Do these logs show anything meaningful?

/opt/bitnami/var/log/post-start.log
/opt/bitnami/var/log/pre-start.log

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

hey Javier,

exact steps to replicate

  1. log into Azure
  2. create VM with alfresco community image (Australia South East)
    2.1 set an auto shutdown 11PM for example
  3. set IP to static in Azure
  4. log in and use alfresco :thumbsup:
  5. auto shutdown triggers
  6. i have an auto startup script for all my VM’s 7AM
  7. go to alfreso / share
  8. cannot log in

sorry i cannot run the logs, i ended up deleting the VM in frustration. i haven’t put the autoshutdown on this environment yet (i’m a bit sick of deleting and re-installing :stuck_out_tongue: )

oh also interestingly on the new instance i deployed i get a permission denied when i run the above log commands

Hi,

I tried to reproduce the issue but I was unable.

  • Set static IP

  • Added auto-shutdown

  • Waited and the instance shut down

  • Then I started it and logged in without issues

The only thing that’s different is the Australia South East, but I don’t think that’s the issue.

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

So was your a manual restart after shutting down the machine? I wonder if there is a difference in the startup script doing this.

It doesn’t make any sense :sob:

Hi,

Maybe I’m missing a step. Could you show some screenshots or a screencast that I can follow?

Yeah I’ll build it out. I don’t really want to turn it off again to be honest :rofl: