Cannot load modules/libphp7.so

Hello

I am using Bitnami’s Lampstack 7.4.6-1 and everything has been running fine until my CentOS 8 updated itself today. Now I cannot run Apache. I get the following message:

Cannot load modules/libphp7.so into server: /lib64/libk5crypto.so.3: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b apache config test fails, aborting

I presume the OS update changed something. Please advise how I can fix this.

Thank you,

Charles

Hi @cburkitt,

In order to reproduce the issue and help you, we need you to provide the following information:

  • Were you using CentOS 8 previously or did the machine updated from CentOS 7 to CentOS 8?

I understand you get this error when starting/restarting the services, is this correct?

  • Can you check if you can install the krb5-libs package?
yum install krb5-libs
  • Is there any other version of that library in the machine?
find / -name libk*crypto.so*
  • What version of OpenSSL do you have?
openssl version
which openssl

Thanks

Hi Jota

Thank you for responding.

I was using CentOS 8 already. This was a new installation of CentOS 8 in January and so far it has been running very well. There are occasionally some small software updates but yesterday’s took a while so I suppose it was a larger update than usual.

When I run ./ctlscript.sh start mysql starts without issue but apache fails to start, with the message above.

find / -name libk*crypto.so* yields:

/usr/lib64/libk5crypto.so.3 /usr/lib64/libk5crypto.so.3.1

openssl versionOpenSSL 1.1.1c FIPS 28 May 2019

which openssl/usr/bin/openssl

I ran yum install krb5-libs and got the response:

Package krb5-libs-1.17-18.el8.x86_64 is already installed. Dependencies resolved. Nothing to do. Complete!

Please let me know if you need more information. Thanks for looking into this.

Charles

Hi @cburkitt,

Thank you for the information. I tried to install the stack in a fresh CentOS 8 deployment and I got the same error when starting Apache. Our team will take a look at this and will update this ticket once we have more information.

Sorry for the inconvenience.

Thanks for your help, Jota.
I’m glad to hear it wasn’t something I was doing wrong!
Charles

Hi @cburkitt,
I was also able to reproduce this issue. It seems this is happening with some of our installers in more than one distro. We have an internal task to investigate this deeper and fix the libraries we are shipping if needed. I linked this case too our internal task.
We will investigate it and get back to you, but unfortunately we can’t provide an ETA on this.

Hi @miguelaeh
Thank you very much for looking into this.
C

Dear all

Any update as I am facing same issue with multiple versions of lampp

Thanks and pleaese help

Hi @rijuvan.ansari,
I am afraid we didn’t have the time to work on this.
We are sorry for the inconveniences this could be creating.
We will update this thread as far as we fix the issue.
Regards.

I am also having the same issue while installing wordpress stack.

wordpress]# ./ctlscript.sh start
/var/www/wordpress/mysql/scripts/ctl.sh : mysql  (pid 2372) already running
httpd.bin: Syntax error on line 160 of /var/www/wordpress/apache2/conf/httpd.conf: Cannot load modules/libphp7.so into server: /lib64/libk5crypto.so.3: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b
apache config test fails, aborting
 wordpress]#

Package krb5-libs-1.17-18.el8.x86_64 is already installed.

]# find / -name libk*crypto.so*
/usr/lib64/libk5crypto.so.3.1
/usr/lib64/libk5crypto.so.3

Please help.

Hi @ramshadcp,
I am afraid we have limited resources and we didn’t have the time to work on this. We have a task opened in our side to fix this issue. As far as we work on it, we will update this thread with more information.
Sorry for the inconveniences.
Regards.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.