Cannot launch Bitnami Wordpress

Keywords: WordPress - Windows - Technical issue - Other
Description:
I have a couple of weird problems with my Bitnami installation. I got the latest installer from the website. The 2 issues that I have found are:

  1. Upon the completion of my installation, instead of launching the browser, my Documents folder got opened (I know it sounds very strange but that’s exactly what happened)

  2. When I open manager-windows.exe, I can see that my MySql service and Apache service are running but clicking any of the buttons (Go to Application, Open phpMyAdmin, Open Application Folder, Visit Bitnami) on the Windows tab do nothing. Not sure how to launch Bitnami wordpress.

Since then I have tried to uninstall Bitnami Wordpress from my machine, removed all the services that were installed with it and retried the installation but nothing seems to work.

I have also tried to install Bitnami WAMP but have the same problem.

Any help will be much appreciated. I am new to Bitnami so please let me know if I need to check something else to get this working. This is the installation guide that I followed to do my Bitnami Wordpress installation - https://docs.bitnami.com/installer/get-started/

I am using Windows 10 - version 1903.

I cannot even run the bitnami support tool.

Hi @anvaykumar,

If all the services are running when using the manager tool, can you open your browser and access the http://127.0.0.1 site? This should open the Bitnami Welcome page and it will redirect you to the WordPress’ page when clicking on the link. Does that work for you?

Thanks

Hello @jota,

Thank you for your prompt reply. I currently have this version of Bitnami Wordpress installed (bitnami-wordpress-5.2.2-2-windows-x64-installer).

When I browse to http://172.0.0.1, I get the option to click on ‘Access WordPress’. But once I click on it, I am re-directed to a page which says 'Error establishing a database connection’.

Moreover, when I browse to http://127.0.0.1/phpmyadmin/ and try to login using the username ‘root’ and password ‘’ (as per the config.inc.php) I always get the message - ‘Login without a password is forbidden by configuration (see AllowNoPassword)’. I changed the ‘AllowNoPassword’ property in the config file from true to false, but still can’t seem to connect.

I have also checked that at this point both MySql and Apache services are running.

I tried looking into the mysqld.log located in C:\Bitnami\wordpress-5.2.2-2\mysql\data and this is what I have in my log file:


2019-07-19T11:21:24.610073Z 0 [Warning] [MY-011068] [Server] The syntax ‘expire-logs-days’ is deprecated and will be removed in a future release. Please use binlog_expire_logs_seconds instead.
2019-07-19T11:21:24.610375Z 0 [System] [MY-013169] [Server] C:\Bitnami\WORDPR~1.2-2\mysql\bin\mysqld.exe (mysqld 8.0.16) initializing of server in progress as process 16972
2019-07-19T11:21:24.614138Z 0 [Warning] [MY-013242] [Server] --character-set-server: ‘utf8’ is currently an alias for the character set UTF8MB3, but will be an alias for UTF8MB4 in a future release. Please consider using UTF8MB4 in order to be unambiguous.
2019-07-19T11:21:24.614163Z 0 [Warning] [MY-013244] [Server] --collation-server: ‘utf8_general_ci’ is a collation of the deprecated character set UTF8MB3. Please consider using UTF8MB4 with an appropriate collation instead.
2019-07-19T11:21:29.458813Z 0 [Warning] [MY-010161] [Server] You need to use --log-bin to make --expire_logs_days work.
2019-07-19T11:21:30.938928Z 5 [Warning] [MY-010453] [Server] root@localhost is created with an empty password ! Please consider switching off the --initialize-insecure option.
2019-07-19T11:21:33.071625Z 0 [System] [MY-013170] [Server] C:\Bitnami\WORDPR~1.2-2\mysql\bin\mysqld.exe (mysqld 8.0.16) initializing of server has completed
2019-07-19T11:21:35.185566Z 0 [Warning] [MY-011068] [Server] The syntax ‘expire-logs-days’ is deprecated and will be removed in a future release. Please use binlog_expire_logs_seconds instead.
2019-07-19T11:21:35.185677Z 0 [System] [MY-010116] [Server] C:\Bitnami\WORDPR~1.2-2\mysql\bin\mysqld.exe (mysqld 8.0.16) starting as process 10204
2019-07-19T11:21:35.188437Z 0 [Warning] [MY-013242] [Server] --character-set-server: ‘utf8’ is currently an alias for the character set UTF8MB3, but will be an alias for UTF8MB4 in a future release. Please consider using UTF8MB4 in order to be unambiguous.
2019-07-19T11:21:35.188452Z 0 [Warning] [MY-013244] [Server] --collation-server: ‘utf8_general_ci’ is a collation of the deprecated character set UTF8MB3. Please consider using UTF8MB4 with an appropriate collation instead.
2019-07-19T11:21:37.126088Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2019-07-19T11:21:37.207698Z 0 [System] [MY-010931] [Server] C:\Bitnami\WORDPR~1.2-2\mysql\bin\mysqld.exe: ready for connections. Version: ‘8.0.16’ socket: ‘’ port: 3306 MySQL Community Server - GPL.
2019-07-19T11:21:37.308749Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: ‘::’ port: 33060
2019-07-19T11:22:55.870376Z 0 [Warning] [MY-011068] [Server] The syntax ‘expire-logs-days’ is deprecated and will be removed in a future release. Please use binlog_expire_logs_seconds instead.
2019-07-19T11:22:55.870562Z 0 [System] [MY-010116] [Server] C:\Bitnami\WORDPR~1.2-2\mysql\bin\mysqld.exe (mysqld 8.0.16) starting as process 11216
2019-07-19T11:22:55.891280Z 0 [Warning] [MY-013242] [Server] --character-set-server: ‘utf8’ is currently an alias for the character set UTF8MB3, but will be an alias for UTF8MB4 in a future release. Please consider using UTF8MB4 in order to be unambiguous.
2019-07-19T11:22:55.891315Z 0 [Warning] [MY-013244] [Server] --collation-server: ‘utf8_general_ci’ is a collation of the deprecated character set UTF8MB3. Please consider using UTF8MB4 with an appropriate collation instead.
2019-07-19T11:22:57.154597Z 0 [System] [MY-010229] [Server] Starting crash recovery…
2019-07-19T11:22:57.178017Z 0 [System] [MY-010232] [Server] Crash recovery finished.
2019-07-19T11:22:58.442037Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2019-07-19T11:22:58.518644Z 0 [System] [MY-010931] [Server] C:\Bitnami\WORDPR~1.2-2\mysql\bin\mysqld.exe: ready for connections. Version: ‘8.0.16’ socket: ‘’ port: 3306 MySQL Community Server - GPL.
2019-07-19T11:22:58.593080Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: ‘::’ port: 33060

I also found that someone else in the community had the same issue and the suggested solution seemed to work for some people - What is the default phpMyAdmin password?

I have tried my custom password that I had set when I was installing Bitnami Wordpress but still can’t seem to login into phpMyAdmin

Hello @jota,

I am now able to access the phpMyAdmin page.
I changed the ‘AllowNoPassword’ property in the config.inc.php file and restarted my services. That seemed to do the trick for me.

However, I am still getting the ‘Error establishing a database connection’ message when I click on ‘Access WordPress’ on http://172.0.0.1

I am just starting to use Bitnami WordPress for the first time so any help would be appreciated. Thanks

Hi @anvaykumar,

Can you ensure that all the services are running when accessing your site?

https://docs.bitnami.com/installer/faq/windows-faq/administration/control-services-windows/

If they are running, we have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please download and execute it by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code outputted by the tool in your reply.

We will let you know how to check the database status once we have more information.

Thanks

Hello @jota,

Thank you for your help.

I can confirm that both the ‘MySQL’ and ‘Apache’ services are running at the time I click ‘Access WordPress’ on http://127.0.0.1/.

I downloaded and ran the Support Tool which, I believe, might have been uploaded to Bitnami servers. The code that I received is 934fd78a-6743-341e-70ec-56fe185a74d5

Regards,
Anvay

Hi, @anvaykumar.

I have not been able to reproduce your issue on a fresh install of Windows 10 build 1903, except for the part about the Documents folder opening.

I can access my Wordpress site at http://127.0.0.1/wordpress/ and I can log into http://127.0.0.1/phpmyadmin/ with the user root and the password I set on the Bitnami installer.

Can you try to login to phpmyadmin with the MySQL user and password that you can find in your apps\wordpress\htdocs\wp-config.php file?

/** MySQL database username */
define( 'DB_USER', 'bn_password' );

/** MySQL database password */
define( 'DB_PASSWORD', 'yourpassword' );

Regards,
Alejandro

Hello @amoreno,

Thank you for your help.

So I tried logging in with what my username and password which is set in the apps\wordpress\htdocs\wp-config.php file. That gives me an error with the following message:

Cannot log in to the MySQL server
mysqli_real_connect(): (HY000/1045): Access denied for user ‘bn_wordpress’@‘localhost’ (using password: YES)

I also tried logging into http://127.0.0.1/phpmyadmin/ using the user root and the password that I had set on installation, but even that doesn’t allow me to log in and presents me a similar error message:

mysqli_real_connect(): (HY000/1045): Access denied for user ‘root’@‘localhost’ (using password: YES)

Can I please confirm that the password that I had set during the installation is supposed to be updated in the apps\phpmyadmin\htdocs\config.inc.php file?
Because according to this file, my username is set to ‘root’ and password is set to ‘’. Unfortunately, even that doesn’t allow me to log in.
But if I change the ‘AllowNoPassword’ property in this config file, I can log in using the username ‘root’ and a blank password.

The next thing that puzzles me is this - according to the apps\wordpress\htdocs\wp-config.php file, below is what my DB should be called along with some other details:

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for WordPress */
define( ‘DB_NAME’, ‘bitnami_wordpress’ );

/** MySQL database username */
define( ‘DB_USER’, ‘bn_wordpress’ );

/** MySQL database password */
define( ‘DB_PASSWORD’, ‘mypassword’ );

/** MySQL hostname */
define( ‘DB_HOST’, ‘127.0.0.1:3306’ );

but when I have gained access to phpMyAdmin using ‘root’ and ‘’, I cannot see a DB with the name ‘bitnami_wordpress’.

The only databases that I see are:

  • information_schema

  • mysql

  • performance_schema

  • sys

Is this expected?

I also find it weird that when I open the manager-windows.exe UI, I cannot click on any of the buttons in the Welcome tab. This is not the case with Manager Servers or Server Events tab, but definitely with the Welcome tab. Is this a known issue or something weird happening with my machine?

I would really appreciate any support to move forward at this stage. Thanks again for your help.

Kind regards,
Anvay

Hi, @anvaykumar.

I don’t see anything wrong in your logs.

Can I please confirm that the password that I had set during the installation is supposed to be updated in the apps\phpmyadmin\htdocs\config.inc.php file?

No, your password shouldn’t be there. You also shouldn’t have to update that file in any way.

The only databases that I see are:

  • information_schema

  • mysql

  • performance_schema

  • sys

Is this expected?

No, this is not expected. You should definitely have a bitnami_wordpress database there.

Let’s try one last thing: launch the use_wordpress.bat file on your installation directory and try to connect to the database from the command line:

With the root user and the password you set:

C:\Bitnami\wordpress-5.2.2-2>mysql -u root -p -h 127.0.0.1 -P 3306
Enter password: thepasswordyousetoninstallation
[...]
mysql> show databases;

With the bn_wordpress user and the password on your apps\wordpress\htdocs\wp-config.php file:

C:\Bitnami\wordpress-5.2.2-2>mysql -u bn_wordpress -p -h 127.0.0.1 -P 3306
Enter password: thepasswordinyourwp-config.php
[...]
mysql> show databases;

In both cases you should be able to connect and see the bitnami_wordpress database there.

If this doesn’t work, let’s try doing a new installation, since maybe something went wrong during the installation or during the download of the installer:

  • Stop all the services from the manager-windows.exe
  • Execute uninstall.exe

Next, download the installer from here: https://bitnami.com/redirect/to/625000/bitnami-wordpress-5.2.2-2-windows-x64-installer.exe and install it. After finishing the installation, try to connect to the database through the command line as I showed you earlier.

Hopefully it works.

Regards,
Alejandro

Hello @amoreno, @jota

A quick update on the problem that I have been having in regards to Accessing WordPress. It seems to have been resolved now. With the amount of weird stuff that has happened, I am not surprised at the fix but I would like to share it in case someone else bumps into this conversation thread.

In my Windows 10 PC, the command prompt was not working. During the installation of Bitnami Wordpress, at the point of creating the DB, a command prompt like window opens. Since cmd was not even launching in my computer, I thought it might be the source of the problem. In my earlier installations of Wordpress I could not even see the bitnami_wordpress DB in the phpMyAdmin UI. Hence I did a system reset and re-installed Wordpress. This seems to have done the trick and I can now Access Worpress and see the bitnami_wordpress DB along with the other DBs. Now even my cmd prompt opens fine (bonus).

Thank you for you time and patience.

Kind regards,
Anvay

1 Like

Hi, @anvaykumar.

I’m glad you were able to fix your issue. Please, let us know if you find any more problems down the road.

Regards,
Alejandro

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.