Cannot find any running daemon to contact

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Other
bnsupport ID: 7b28d195-9958-39c6-deab-e8cdf438a44b
Description:
Hi,

I’m using Lightsail with your LAMP application. It was working like a charm but now I struggle to display services status (or even start / stop / restart).

When I type sudo /opt/bitnami/ctlscript.sh status, I get this error : Cannot find any running daemon to contact. If it is running, make sure you are pointing to the right pid file (/var/run/gonit.pid)

If I reboot my instance I will be able to use status / start / stop… commands, but not for long. I even try sudo pkill -f without success.

FYI: I’m running a Prestasho website.

I already saw two topics on this subject but it was not the same problem.

Hi @c.codin,

Thanks for using Bitnami. According to your bnsupport bundle, your server is running out of free memory, so it may explain why gonit can’t manage the services.

-----------------------------------
Display amount of free and used memory in the system
-----------------------------------
Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:            482         352          11          25         118          91
Swap:           634         333         301

Can you use a bigger instance type? Find below the official docs to do so

https://aws.amazon.com/premiumsupport/knowledge-center/change-lightsail-plan/

Thanks, but according to prestashop’s minimum requirements, 512 MB should be enough…
How much memory would you recommand for a prestashop in a prod environment ?

Thans for your support :slight_smile:

Hi @c.codin,

Can you try with an instance of 1 Gb of memory? That should be enough according to the memory usage above. Notice that this server is not only running Apache and Prestashop but also the MySQL database which, depending on your website plugins and themes, can be under a high load, which requires more memory.

Hi,

I took the 2Gb version for safety, and I take another dedicated Database instance =)
No more problem.

But I woud like to prevent the mysql service to start since I’m not using it. Do you have any documentations to help me with it ?

Hi @c.codin,

Thanks for the info. I hope your new servers are performing properly. Yes, it is possible to disable the current MySQL server in your server. Please follow the next steps to do so:

  • Stop MySQL
sudo /opt/bitnami/ctlscript.sh stop mysql
  • Disable the service and reload the gonit configuration
sudo mv /etc/monit/conf.d/mysql.conf /etc/monit/conf.d/mysql.conf.disabled
sudo gonit reload

Hi @gongomgra

Wonderful, thanks !

Hi @c.codin,

Thanks for your message. Let us know if we can close this thread as solved.

Regards,
Gonzalo

Hi,

Sorry I didn’t see your reply. Yes you can close it :slight_smile:

Hi @c.codin,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.