Cannot find any running daemon to contact even with debian reboot

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: d7ec8be3-7655-b842-9db9-38f76ec1e919

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues

bndiagnostic failure reason: The documentation did not make any significant change

Me and my team have setup a cms platform that uses imagick/imagemagick to generate pdf thumbnails for our albums when in a gallery view. When we turned on/off the plugin the site would crash and I would restart the services using the supplied command. Now it says it cannot find any running daemon to contact. Where should I go from here? Before the site crashed we built a plugin to calculate storage space and it was at 97%. I have deleted some images/mp4’s to free up space but I doubt that would contribute to a solution. I ran the diagnostic tool and it mentioned apache having errors. The last error was
[Fri Sep 10 21:28:34.000323 2021] [proxy_fcgi:error] [pid 20437:tid 140599319561984] (104)Connection reset by peer: [client IP HIDDEN] AH01075: Error dispatching request to : , referer: SITE HIDDEN

[Fri Sep 10 21:28:36.538940 2021] [mpm_event:notice] [pid 19811:tid 140600301996928] AH00491: caught SIGTERM, shutting down

Where can I go from here?

Hello @gordon.samuel99,

Thanks for using Bitnami WordPress! From what I can see, you have more than enough space:

Check free amount of disk space
Running: df -h
In: /opt/bitnami


Filesystem      Size  Used Avail Use% Mounted on
udev            990M     0  990M   0% /dev
tmpfs           200M  2.9M  197M   2% /run
/dev/xvda1       59G  4.0G   53G   8% /
tmpfs           998M     0  998M   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           998M     0  998M   0% /sys/fs/cgroup
/dev/xvda15     124M  278K  124M   1% /boot/efi
tmpfs           200M     0  200M   0% /run/user/1000

The issue should be related to the fact that System Apache is running:

root 578 0.0 1.2 216684 24876 ? Ss 21:43 0:00 /usr/sbin/apache2 -k start www-data 599 0.0 0.4 216756 9144 ? S 21:43 0:00 /usr/sbin/apache2 -k start

If Bitnami Apache isn’t starting this is the most likely cause. Please run the following command to stop it:

sudo systemctl disable apache2 && sudo systemctl stop apache2 

Francisco de Paz

Thank you fdepaz. Our site is back up and running. Why did I have to disable Apache2? I thought Bitnami was configured to use Apache2?

Hello @gordon.samuel99,

It is indeed configured to use Apache2, but this component is already shipped in the stack and there is no need to install it. Moreover, we do use different paths compared to the ones used by System Apache.

In your case, the issue was caused by the System Apache process being run, as it was using the same port (80) that the shipped Apache would need to use. This was causing for the shipped Apache to be unable to run.

Francisco de Paz