Cannot enable CORS properly no matter what I do

Keywords: Redmine - AWS - Technical issue - Application configuration

bnsupport ID: 65293f38-1e63-5030-f341-9735b501a0f3

bndiagnostic output:

? Resources: Found possible issues

bndiagnostic failure reason: The documentation did not make any significant change

Description:
I have weird issue.
I have configured couple of other redmine instances without no issues, but this AWS Image is not working properly.

I tried all the guides I could find related CORS configuration but none of them help.

I can fetch custom fields / projects even issues I think but as soon as I try to execute POST requests I get CORS error and this confuses me, if I can execute GET why then POST would fail. (I applied same configuration of CORS to other instances and it worked).

The configuration I have applied:
Header always set Access-Control-Allow-Origin ""
Header always set Access-Control-Allow-Methods “POST, GET, OPTIONS, DELETE, PUT”
Header always set Access-Control-Max-Age “1000”
Header always set Access-Control-Allow-Headers “Content-Type, authorization”
RewriteEngine On
RewriteCond %{REQUEST_METHOD} OPTIONS
RewriteRule ^(.
)$ $1 [R=200,L]

Any help? Thought whether could it be related to HTTPS? any help would be appreciated

Hello @lukis0300,

I checked your Apache’s configuration but I didn’t see the CORS config in the HTTP vhost, could you try adding it there and checking if that solves it?

Besides that, did you try making the POST requests to both HTTP and HTTPS domains? Does it make any difference?

Regards,
Francisco de Paz