Cannot connect to MySQL with SSH - Wordpress Nginx + SSL

Hello,

I’ve been dealing with this issue for about 2 months now and still haven’t found a solution. E-commerce WordPress Woocommerce website crashes every day at certain hours due to database connection (502 Bad Gateway Error). I create a virtual machine again with its backup and it works, but it crashes again after about 8-10 hours. This problem creates an incredible loss of customers and reputation.

Nginx already running
php-fpm already running
mysql not running

I want to connect to the database via SSH.

  • mysql -u root -h localhost -p
  • Password:

The system requests a password from me, but the password I typed does not appear (I press the keys on the keyboard, but it does not work)

then I get an error like this

–ERROR 1045 (28000): Access denied for user ‘root’ @ ‘localhost’ (using password: YES)

/opt/bitnami/mysql/bin/mysqladmin.bin Ver 8.0.18 for linux-glibc2.12 on x86_64 (MySQL Community Server - GPL)

PHP Version: 7.3.16

Also, if anyone has experience about why our site crashes periodically after running, I would like to ask you to share.

I’m looking forward to your answers

Thank You!

Hi @dogubeylimay10,

Thanks for using Bitnami. About to access MySQL, writing the password in Linux via console never turn off, write the password and press enter.

About why MySQL isn’t running, you can check the logs, this guide could help you https://docs.bitnami.com/virtual-machine/apps/wordpress-multisite/troubleshooting/debug-errors-mysql/

Regards,
Ibone

Hello Ibone,

I tried again but it does not work, unfortunately. (I cannot write anything)

Do you have more advice?

Thank you.

Hi @dogubeylimay10,

Could you try the following command?

mysql -u root -h localhost -p<PASSWORD>

Remember to replace with your password, but using a password on the command line interface can be insecure.

Regards,
Ibone.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.