Can’t get Bitnami Support Tool ID

Keywords: Magento - AWS - How to - Other

Description:
Im having issues with my crons and try to open and ticket, but when I run sudo /opt/bitnami/bndiagnostic-tool i get this message:


? Apache: Found possible issues
✓ Connectivity: No issues found
✓ Resources: No issues found
? Mysql: Found possible issues
? Php: Found possible issues

[Apache]

Found recent error or warning messages in the Apache error log.

[Mon Jun 20 21:17:15.322930 2022] [proxy:error] [pid 5938:tid 140531212424960] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/bitnami/php/var/run/www.sock (www-fpm) failed
 [Mon Jun 20 21:17:15.322942 2022] [proxy_fcgi:error] [pid 5938:tid 140531212424960] [client 127.0.0.1:48944] AH01079: failed to make connection to backend: httpd-UDS
 [Tue Jun 21 00:16:13.067459 2022] [ssl:error] [pid 28867:tid 140228962526976] [client 34.207.78.56:36802] AH02042: rejecting client initiated renegotiation

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

A high number of incoming requests originate from one or more unique IP addresses. This could indicate a bot attack. The following guide shows how to check for and block suspicious IP addresses.

https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

[Mysql]

Found recent error messages in the MySQL error log:

2022-06-20T23:26:10.534501Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release.

Please check the following guide to troubleshoot MySQL issues:

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mysql/

[Php]

The following error appears in the /opt/bitnami/php/var/log/php-fpm.log:

[21-Jun-2022 00:41:29] WARNING: [pool www] server reached max_children setting (5), consider raising it

This error usually indicates PHP script execution is slow due to busy server resouces or buggy scripts. Please check the following guide to increase the number of PHP-FPM child processes:

https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/


If I try to open a topic selecting “Bitnami Support Tool” the next button is no show I can continue…

If i run sudo df -h
Filesystem Size Used Avail Use% Mounted on
udev 7.7G 0 7.7G 0% /dev
tmpfs 1.6G 41M 1.5G 3% /run
/dev/nvme0n1p1 50G 32G 16G 67% /
tmpfs 7.7G 0 7.7G 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 7.7G 0 7.7G 0% /sys/fs/cgroup
/dev/nvme0n1p15 124M 262K 124M 1% /boot/efi
tmpfs 1.6G 0 1.6G 0% /run/user/1000
tmpfs 1.6G 0 1.6G 0% /run/user/996

sudo free -m
total used free shared buff/cache available
Mem: 15666 2675 9265 139 3726 12535
Swap: 634 0 634

uptime
01:05:27 up 19:58, 1 user, load average: 0.37, 0.24, 0.18

sudo /opt/bitnami/ctlscript.sh status
varnish already running
php-fpm already running
apache already running
elasticsearch already running
mysql already running
memcached already running

I stop and restart using sudo /opt/bitnami/ctlscript.sh but nothing happens.

Thank you

Hi @badinmagento,

That’s probably due to the amount of data you have in the instance and the tool is probably trying to grab a big file/log from there.

Did you try to stop the services, run the tool and start the services again?

sudo /opt/bitnami/ctlscript.sh stop
sudo /opt/bitnami/bndiagnostic-tool
sudo /opt/bitnami/ctlscript.sh start

Thank you for the reply.

I did it but I got the same error.

That’s weird, but let’s start helping you with the real issue. Could you please give us more details about the issues with the cron jobs you are running into? Please note that if those errors are app-related errors, it’s better to contact the Magento’s support team to get more information about them.