Can’t get access to wp-config.php on google cloud

Keywords: General - Google Cloud Platform - Technical issue - Connectivity (SSH/FTP)
Description:
Hello guys,

I few months ago I try to unlock wp-config.php file and it worked for me with this commands:

sudo -s

sudo chmod 664 /opt/bitnami/apps/wordpress/htdocs/wp-config.php

(Change it back):

sudo chmod 660 /opt/bitnami/apps/wordpress/htdocs/wp-config.php

, but today when I trying to get access to wp-config.php file I’m getting this msg:

hmod: cannot access ‘/opt/bitnami/apps/wordpress/htdocs/wp-config.php’: No such file or directory.

I try to watch Fixing WordPress permissions video: https://youtu.be/nKfle7O0vN8

, but still nothing. Only this msg:

chown: cannot access ‘/opt/bitnami/apps/wordpress/htdocs’: No such file or directory

Any suggestions?

I want to enable W3 Total Cache plugin inside multisite, but getting this error:

W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.

Please execute commands manually
or use FTP form to allow W3 Total Cache make it automatically.

Edit file /opt/bitnami/wordpress/wp-config.php and add next lines:

and don’t know how to get access to edit wp-config.php file

Hi @carlharvey

Thanks for using Bitnami WordPress!

, but today when I trying to get access to wp-config.php file I’m getting this msg:
hmod: cannot access ‘/opt/bitnami/apps/wordpress/htdocs/wp-config.php’: No such file or directory.

chown: cannot access ‘/opt/bitnami/apps/wordpress/htdocs’: No such file or directory

We are in the process of modernizing all of our stacks and WordPress was updated recently as part of this program. As a result, certain paths in the stack may have slightly changed (and that is why the file does not exist). To learn more about this changes, please refer to:

https://docs.bitnami.com/google/faq/get-started/understand-upcoming-changes/

I try to watch Fixing WordPress permissions video:

In order to fix the permissions, please refer to this updated guide:

https://docs.bitnami.com/google/apps/wordpress/administration/understand-file-permissions/

In your case, the keyword TARGET should be substituted by /opt/bitnami/wordpress.

I want to enable W3 Total Cache plugin inside multisite, but getting this error:

Could you try fixing the permissions and see if that solves this issue as well?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.