Can’t connect to Kafka packaged by Bitnami on GCP

Keywords: Kafka - Google Cloud Platform - How to - Other

Description:

  • I can’t connect to Kafka on GCP. I configured the fire wall rule to open 9092 port for Ingress and Egress, but it still not working.
  • I tried access from inside the instance with this command ‘/opt/bitnami/kafka/bin/kafka-console-consumer.sh --bootstrap-server localhost:9092 --topic test --from-beginning’
  • but I got a error ‘[2022-02-09 03:44:28,239] WARN [Consumer clientId=console-consumer, groupId=console-consumer-51277] Bootstrap broker localhost:9092 (id: -1 rack: null) disconnected (org.apache.kafka.c
    lients.NetworkClient)’
  • I checked the Kafka status(‘sudo /opt/bitnami/ctlscript.sh status’): Kafka and Zookeeper already working

Hi @tumai,

We test all our solutions before making them public and ensure they all work as expected. One of the tests we perform for Kafka is the creation of topics and consume them. I suggest you take a look at the Kafka’s documentation to get more information about how to create a topic and how to consume it. You can also contact the Kafka’s developers to get more information about that.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.