Can not connect to SSH console

Type: Bitnami Support Tool

Description:
Can not connect to SSH console, so there is no way to run support tool.

Error messages…
The key transfer to project metadata is taking an unusually long time. Transferring instead to instance metadata may be faster, but will transfer the keys only to this VM. If you wish to SSH into other VMs from this VM, you will need to transfer the keys accordingly.
Click here to transfer the key to instance metadata. Note that this setting is persistent and needs to be disabled in the Instance Details page once enabled.
You can drastically improve your key transfer times by migrating to OS Login.

Click here to transfer the key to instance metadata…CLICKED, BUT STILL CAN NOT CONNECT.

Thanks

Hi @mubiesam

I’m sorry to hear that!

What cloud provider are you launching your instance on? Are you using Bitnami Launchpad?

The key transfer to project metadata is taking an unusually long time.

From my experience, this is usually a transient error. Retrying within a few minutes should solve the issue and you’d be able to connect to your instance again. Do you keep experiencing issues?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

Yes, I was using Bitnami Launchpad to create our site on GCP.

Had used SSH console for a long time without any problem until recently, and it keep on happening until this moment.

Any suggestion…
Thanks

Hi again @mubiesam

A couple of questions:

  1. Are you launching a brand new instance or trying to connect to an existing instance you created some time ago?
  2. Do you have any other instance to try and test the SSH connection to them?
  3. Is the instance you are trying to connect running? Can you access to any other port of the instance (for example, can you navigate to it using your web browser)?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

We have 3 Virtual Machines on Bitnami Launchpad, all running well on web browser.

Two of them can connect to SSH console without problem, but the most important one is not. We had connected to SSH console for this one in the past 2 months, but getting this problem recently.

Thanks

Hmm that is strange in fact. Please, make sure that the instance is running and execute the following commands from your console:

nc -zv YOUR_INSTANCE_IP 22
nc -zv YOUR_INSTANCE_IP 80

Let’s try to see if this is something related to ports. Note that you will have to replace YOUR_INSTANCE_IP with your actual instance IP.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

Since I can not connect to ssh console, so I used WinSCP terminal

Got
Connection to my_instance_ip 22 port [tcp/http] succeeded!
Connection to my_instance_ip 80 port [tcp/http] succeeded!

But command error 0

see screenshot…https://photos.app.goo.gl/HhWX9zXVtsWCgn2Q8

Hi @jcarmona

I made a change in permalinks, but got 404 errors. Tried to find answer but got a lot of outdated discussion which led to outdated links or old path for .htaccess file

Meanwhile, since I cannot connect to ssh console now, so I can not restart apache.

Sorry to bother you, but do need your help urgently…

Thank you very much!

Hi @mubiesam

It seems that your instance is running and that the SSH and HTTP ports are open. Furthermore, you have successfully executed the commands I provided from within your instance and you are connected to it using SFTP.

We have a guide that covers how to connect to your instance using PuTTY, a free SSH client for Windows. It would be nice if you can give it a try as an alternative to the browser’s SSH connection you were used to. With that, let’s try to see if the connection succeeds:

  1. Follow this guide to obtain your SSH credentials (if you don’t have it already on your computer): https://docs.bitnami.com/google/faq/get-started/connect-ssh/#obtain-ssh-credentials

  2. Then, follow this guide to configure PuTTY to your instance:
    https://docs.bitnami.com/google/faq/get-started/connect-ssh/#connect-with-an-ssh-client-on-windows-using-an-ssh-key

Can you please try that and report back?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

The SSH connection using PuTTY is working now.

Can you guide me to solve the 404 error first…
I had followed Default .Htaccess File Configuration to change “AllowOverride None to All” in wordpress-vhost.conf, but it seems that I should change in wordpress-htaccess.conf too, is that correct? what should I add?

Thanks

Hello @mubiesam,

Now that you can access your instance, could you please execute our Support Tool on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Regards,
Francisco de Paz

41c7b12d-fa21-9433-19e5-1129ce6fd7ae

Thanks

Hello @mubiesam,

I checked your site and I didn’t encounter any 404 errors, did you solve the issue? Making the change at apache/conf/vhosts/wordpress-vhost.conf and apache/conf/vhosts/wordpress-https-vhost.conf, but you can add the following to apache/conf/vhosts/htaccess/wordpress-htaccess.conf if it is needed:

<Directory "/opt/bitnami/wordpress">
    Options -Indexes +FollowSymLinks -MultiViews
    AllowOverride All
    Require all granted
</Directory>

Regards,
Francisco de Paz

1 Like

Yes, I had modified the 2 files as you mentioned, thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.