Bootcamp windows10 MySQL database cannot running

I use bootcamp windows10. MySQL database cannot running, but Apache websever is running well.

log file contents has below. I don't know why it stopped. please help me and give me some advice.

really thanks.

2017-03-19 17:00:54 204c InnoDB: Operating system error number 87 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html
2017-03-19 17:00:54 10928 [ERROR] InnoDB: File .\ib_logfile0: 'aio read' returned OS error 187. Cannot continue operation

Hi @Luka,

Could you please answer the following questions?

  • What Bitnami stack did you install in your Windows machine?
  • Did you perform any changes in the configuration file of the database before running into this issue?
  • Could you please check this Stack OverFlow case and let us know if it works for you?

http://stackoverflow.com/questions/22461872/configuration-of-mysql-server-installation-failed-or-cant-start-the-service

Regards,
Jota

Thanks your comments. I am Korean so my english skill not enough, please understand me.

  1. WAMP Stack 5.630-1 Rev.1

  2. I didn't any changes in conf file.

  3. I did adjust that My.ini file. but it still not working.

Now my conf file contents has below.

[client]
default-character-set=UTF8

[mysqladmin]
user=root
port=3306

# The MySQL server
[mysqld]
# set basedir to your installation path
basedir="C:/Bitnami/wampstack-5.6.30-1/mysql"
# set datadir to the location of your data directory
datadir="C:/Bitnami/wampstack-5.6.30-1/mysql/data"
port=3306
character-set-server=UTF8
collation-server=utf8_general_ci
max_allowed_packet=32M
bind-address=127.0.0.1
# The default storage engine that will be used when create new tables when
default-storage-engine=INNODB

log-error="C:/Bitnami/wampstack-5.6.30-1/mysql/data/mysqld.log"
[mysqldump]
max_allowed_packet=32M

[mysql]
port=3306

innodb_flush_method=normal

Hi @Luka,

Could you please add that setting inside the [mysqld] section? As you can see, there are some sections in the configuration file (client, mysqladmin, mysqld, ...) and you need to add that line inside the mysqld section.

...
[mysqld]
innodb_flush_method=normal
...

Then, restart the server, access MySQL and run this command:

https://docs.bitnami.com/installer/components/mysql/#how-to-connect-to-the-mysql-database
https://docs.bitnami.com/installer/components/bnconsole/

show variables like 'innodb_flush_method';

Regards,
Jota

1 Like

Yes!!! I solve this problem!!!!!!!!!! Thanks a lot!!!

1 Like

Hi @Luka,

I'm really glad to hear that :smile: Thank you for letting us know.

Jota

Hi Jota,

I have the same problem with Luka, but I use XAMPP Stack 7.2.3-0.

Could you please help me to fix this problem?

Many thanks in advance.

hello, please help me, my problem is same but I use xampp and cannot running MySQL, please give me step by step to fix this, thank you so much.

Hi @Tria

Are the services running? Could you please use the Manager available on the XAMPP installation and let us know if MySQL service is running?

We also have a Support Tool that will gather relevant information for us to debug the issue. Could you please download and execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code outputted by the tool in your reply.

Best Regards,

Juan Ariza

A post was split to a new topic: Can’t start database after Windows update