BNCERT Tool can not find bitnami installation location

Type: Bitnami Support Tool

Description:
I just created this instance with Bitnami for wordpress on AWS, not the nginx version but the normal version with Apache in it. Both the bncert-tool and cnbndiagnostic-tool are already there.

When I run them, both say it couldn’t find bitnami installation. I typed “/opt” and “opt/bitnami”, didn’t work, it keeps the loop of entering Bitnami directory. But bitnami directory is right there, as a new instance, there shouldn’t be anything missing.

I tried to download the latest version of bncert-tool, the same thing. And I’m pretty sure mine isn’t the “nginx + SSL” verision.

Hello All,

I am also facing the same problem and looking forward if any help/guidance is provided on this issue.

There’s a reply from another thread, it works:

We checked the bndiagnostic tool on our side and it seems to be an issue with our recent images. Can you please update the /opt/bitnami/properties.ini file and add the next line right below the [General] section line?

installdir=/opt/bitnami

After that, running the bndiagnostic tool should work. If it does, please open a new “Technical issue” thread for your issue providing the generated code.

Thanks for the response.
image

I am getting the warning to fix DNS. So do I need to perform any explicit steps before this?

Hello @dilipbglr30p,

With the suggestion from @joshfan you should be able to run a new support tool, right? Please open a new ticket as Technical Issue instead of Bitnami Support Tool:

Screenshot 2021-07-16 at 10.05.30

Regards

As guide raised a new ticket.

Hi, we have identified the problem and released a new version of the bncert (0.7.2) and bndiagnostic (0.9.17) tools with a fix for the errors. If you launch the current version of the tool, it should detect the new version and attempt to download it.

If it doesn’t detect it, you can always download bncert manually:

https://downloads.bitnami.com/files/bncert/0.7.2/bncert-0.7.2-linux-x64.run
md5: 7170b9d68641f5a045a5e6e4b5772a3a

And for bndiagnostic:

https://downloads.bitnami.com/files/bndiagnostic/0.9.17/bndiagnostic-0.9.17-linux-x64.run
md5: e813e84f0fad054e39eba4508157b489

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.