Blank screens (Issue Tracker Management and Test Case Execution)

Keywords: TestLink - AWS - Technical issue - Other
bnsupport ID: cf39cad0-15bc-57f1-2978-24583f1ab04e
Description:
Some screens are not rendering on the right pane. I tried adding a third Issue Tracker and hit save. Now the right pane is blank when I try to view the list of Instances. It did get created (the third one) because it shows in the drop down when setting up Issue tracker for the project. Also, now when I go to execute test cases, nothing in the right as well to allow me to see and complete them.

When using Chrome and selecting Issue Tracker Management, the pane below the top tool bar goes completely blank. When using IE, I get “The website can not be display the page” and More information says “This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.”

Same thing when I go to Execute the Test (put only an issue for the Project that is set to use the new issue tracker.

I was trying to add Trac (redmine is working fine).

Hi @katie.raezer,

Thanks for using Bitnami. I see the next error in your Apache log. Can you check it?

[Thu Apr 01 13:03:35.982472 2021] [proxy_fcgi:error] [pid 679:tid 139639092365056] [client 71.72.63.201:51924] AH01071: Got err│
or 'PHP message: PHP Parse error:  syntax error, unexpected 'new' (T_NEW) in /opt/bitnami/testlink/third_party/phpxmlrpc/lib/xm│
lrpc.inc on line 554', referer: http://IP_ADDRESS/lib/general/mainPage.php

Apart from that, it looks like your server is running out of free memory.

-----------------------------------
Display amount of free and used memory in the system
-----------------------------------
Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:            987         413         124          19         450         417
Swap:           634           0         634

Can you increase the instance type?

https://docs.bitnami.com/aws/faq/administration/change-server-type/

i tried removing “new” and restarting but still same issue.
After

before it read $temp =& new xmlrpcval…
could only post one image

Trying to figure out how to make large instance as well

So I went through and deleted like 50 instances of the ‘new’ and it fixed it. Kept retrying and the apache error would show another error about the ‘new’ in the statement. So I decided to remove them all and my issue is fixed. Thanks!!!

Hi @katie.raezer,

Thanks for the info. I’m glad you fixed your issue. However, we recommend you to double-check the changes with the application developers. Maybe the PHP version our images include isn’t valid for the plugin you are using and that’s why you were getting those syntax errors.

https://forum.testlink.org/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.