Blank screen after installing SSL on Parse Server

Keywords: Parse - AWS - Technical issue - Secure Connections (SSL/HTTPS)
bnsupport ID: 8b17f914-1907-6a27-db63-2c6542c138f2
Description:
I installed SSL on my parse server which is hosted on AWS.
After logging in on the parse dashboard, I see black screen.
I used the domain apps.weaponoid.com
I have even changed my server url to https://apps.weaponoid.com/parse and restarted my server. But still blank screen is shown.
I installed SSL with bncert-tool .
But when I access my Parser Server dashboard with AWS EC2 IP address i.e. http://65.0.187.3/ , everything works.
Please help

I opened my parse dashboard in chrome devtools.
In the console the following error is shown

dashboard.bundle.js:82 Mixed Content: The page at 'https://apps.weaponoid.com/apps' was loaded over HTTPS, but 
requested an insecure XMLHttpRequest endpoint 'http://65.0.187.3/parse/serverInfo'. This request has been blocked; 

the content must be served over HTTPS.

Hi @weaponoid

Thanks for using Bitnami Parse!

How did you perform this step? I am trying to reproduce your issue and any further step will be very much appreciated.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

I figured that out, this error is only there if parse dashboard is opened from my https url in any browser.
But for parse sdk in android or ios, the https url works without any problem.

Hi @weaponoid

Did you follow this guide in order to set up HTTPs?
https://docs.bitnami.com/aws/apps/parse/administration/forcehttps/

Could you please run the following command to see the content of your server.js file?

cat /opt/bitnami/parse-dashboard/server.js | grep serverURL

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.