Bitnami Support Tool not found

Type: Bitnami Support Tool

Description:
Once Bitnami Wordpress is loaded and running. I try to start. The Hello page does not have the Manage Button.
I tried the Btnami Support Tool and received the response No Such File or Directory.
MacArthur2@Arthurs-iMac ~ % wget -O bnsupport-linux-x64.run https://downloads.bitnami.com/files/bnsupport/latest/bnsupport-linux-x64.run
sudo mkdir /opt/bitnami/bnsupport
sudo mv bnsupport-linux-x64.run /opt/bitnami/bnsupport/
sudo chmod +x /opt/bitnami/bnsupport/bnsupport-linux-x64.run
sudo ln -s /opt/bitnami/bnsupport/bnsupport-linux-x64.run /opt/bitnami/bnsupport-tool
zsh: command not found: wget
mkdir: /opt/bitnami: No such file or directory
mv: rename bnsupport-linux-x64.run to /opt/bitnami/bnsupport/: No such file or directory
chmod: /opt/bitnami/bnsupport/bnsupport-linux-x64.run: No such file or directory
ln: /opt/bitnami/bnsupport-tool: No such file or directory
MacArthur2@Arthurs-iMac ~ %

Hi @abarber2,

Thanks for using Bitnami. I understand you are using our Bitnami WordPress OS X VM, is that correct? If so, you need to run the commands from the virtual machine’s terminal, which you can access by clicking the Open Terminal button in the control panel once the virtual machine is started.

Also, the bnsupport tool should be already installed in the machine. Can you check it?

The Hello page does not have the Manage Button.

About this, do you mean the Bitnami button in the bottom right corner of the WordPress site? This feature has been removed in recent versions of the asset, but you can get the credentials from the VM’s console by running the next command

cat /home/bitnami/bitnami_credentials

I ran the code you asked me to run and this is what I get:

Last login: Wed Aug 25 06:50:10 on ttys001

MacArthur2@Arthurs-iMac ~ % cat /home/bitnami/bitnami_credentials

cat: /home/bitnami/bitnami_credentials: No such file or directory

MacArthur2@Arthurs-iMac ~ %

How do I get into the WP-admin to work with it?

username? is it: user

password? is it: bitnami

Thanks,

Arthur

Hi @abarber2,

Thanks for your message. Notice you are running the commands into your OS X’s terminal, and not into the OS X VM’s terminal. You need to first click the “Open Terminal” button I highlighted in my previous message screenshot to get the new terminal opened. Also notice in the new terminal, the prompt (the header in the line where you enter commands), is root@debian:-# instead of MacArthur2@Arthurs-iMac ~ % that you get in your OS X machine.

When I click on the Open Terminal button, it opens the OS X terminal. It does not open the OS X VM terminal.
I get this: Last login: Thu Aug 26 06:20:25 on ttys001
MacArthur2@Arthurs-iMac ~ %
Any other way to get to the VM terminal?

Thanks,
Arthur

Hi @abarber2,

Thanks for your message. I think I reproduced your issue. The first time I clicked the “Open Terminal” button, it opened a terminal window with the OS X prompt, but if I click the button again without closing that previous terminal, then it works fine. Can you check it?

I clicked on Open Terminal and I get this:
Last login: Wed Sep 8 12:19:45 on ttys001
MacArthur2@Arthurs-iMac ~ %
I clicked on Open Terminal a second time and I still get this:
Last login: Wed Sep 8 12:19:45 on ttys001
MacArthur2@Arthurs-iMac ~ %
I even quit terminal and tried it again.
Still the same.

Hi @abarber2

Can you make sure you have this in your System Preferences?

Open System Preferences and navigate to Security & Privacy. Under the Privacy tab, navigate to Automation. On your right side now, ensure that bash has access to Terminal.

After that, please stop and exit the Bitnami application. Reopen it again and start your stack. Once the Open Terminal button is enabled, is the right prompt shown now?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Success!!!
However, now I get the following message when I click on the Go to Application:

Error establishing a database connection.

One step at a time!

Thanks
Arthur

Hi @abarber2,

Error establishing a database connection.

Are all the services running? You can either access the “Services” tab in the UI or run this command in the terminal

sudo /opt/bitnami/ctlscript.sh status

Thanks

I now have the WP login window.
User name: user
Password: ???

Need help with signing in.

Thanks,
Arthur

Hi @abarber2,

Did you check if all the services were running using the command I posted above?

https://docs.bitnami.com/installer/apps/wordpress/get-started/first-steps/#os-x-vm-227

Happy to help!


Was my answer helpful? Click on :heart:

Yes, I did check the services:
Last login: Tue Sep 14 14:01:04 2021 from 192.168.64.1

root@debian:~# sudo /opt/bitnami/ctlscript.sh status

apache already running

mariadb already running

php-fpm already running

root@debian:~#

I am now getting the connection error again.

Error establishing a database connection

What can be causing this error?

Thank you for your help.
Is there anyway to talk to someone live so I can try things as we diagnose them?

thanks,

Arthur

Hi @abarber2,

Did you modify the wp-config.php file and changed the database configuration? If MariaDB is running, the application shouldn’t be throwing errors when connecting to the database. You can check the connection by running this command

mysql -u DATABASE_USER -p DATABASE_NAME

I have not modified the wp-config.php file or changed the dabase configuration. I cannot even get into the thing.
this is what I get
*** Welcome to the Bitnami WordPress 5.8.0-11 ***
*** Documentation: https://docs.bitnami.com/installer/apps/wordpress/ ***
*** https://docs.bitnami.com/installer/ ***
*** Bitnami Forums: https://community.bitnami.com/ ***
Last login: Tue Sep 14 14:01:04 2021 from 192.168.64.1
root@debian:~# mysql -u DATABASE_USER -p DATABASE_NAME
Enter password:
ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/opt/bitnami/mariadb/tmp/mysql.sock’ (111)
I am about ready to remove this program form my computer.
This is taking to long to solve the problem.
I ask again, can someone talk me through this over the phone?

Thanks,
Arthur

Hi @abarber2,

The command I posted included PLACEHOLDERS that you needed to substitute before running the command. You can get the values of those parameters from the wp-config.php.

If you do not have any data in that WordPress VM, you can recreate the environment by removing the ~/.bitnami folder and downloading the latest version from bitnami.com

https://docs.bitnami.com/installer/faq/osx-vm-faq/administration/uninstall-osx-vm/
https://bitnami.com/stack/wordpress/installer

Sorry, but we do not provide that kind of support.