Bitnami Support Tool Keeps loading, no reply shown

Type: Bitnami Support Tool

Description:
While trying to run Bitnami Support Tool, it keeps loading, no reply is shown. Cannot figure out what’s going on… please help!

Hello @alliancelsppc,

The issue could be happening because of insufficient memory. Could you please stop all your services and run again the bnsupport-tool:

sudo /opt/bitnami/ctlscript.sh stop

If the issue persists, please share with us the specific error log it outputs as well as the info obtained from running these commands:

free -m
df -h

Regards,
Francisco de Paz

I tryed that, but I don’t think it’s a memory issue - server is huge!
Take a look:

BEFORE STOP

total        used        free      shared  buff/cache   available
Mem:          63798       37818       22371         121        3607       25235
Swap:             0           0           0
Filesystem       Size  Used Avail Use% Mounted on
udev              32G     0   32G   0% /dev
tmpfs            6.3G  121M  6.2G   2% /run
/dev/nvme0n1p1    98G   49G   46G  52% /
tmpfs             32G     0   32G   0% /dev/shm
tmpfs            5.0M     0  5.0M   0% /run/lock
tmpfs             32G     0   32G   0% /sys/fs/cgroup
/dev/nvme0n1p15  124M  278K  124M   1% /boot/efi
tmpfs            6.3G     0  6.3G   0% /run/user/1000

AFTER STOP

              total        used        free      shared  buff/cache   available
Mem:          63798         385       59809         120        3603       62661
Swap:             0           0           0
Filesystem       Size  Used Avail Use% Mounted on
udev              32G     0   32G   0% /dev
tmpfs            6.3G  121M  6.2G   2% /run
/dev/nvme0n1p1    98G   49G   46G  52% /
tmpfs             32G     0   32G   0% /dev/shm
tmpfs            5.0M     0  5.0M   0% /run/lock
tmpfs             32G     0   32G   0% /sys/fs/cgroup
/dev/nvme0n1p15  124M  278K  124M   1% /boot/efi
tmpfs            6.3G     0  6.3G   0% /run/user/1000

HELP!
Cannot find any running daemon to contact. If it is running, make sure you are pointing to the right pid file (/var/run/gonit.pid)

Server is not running anymore!
@fdepaz

Hello.
After stopping all services, website was down.
I tryed a lot of stuff to bring it back, but nothing worked. But I got some warnings and messages, which I share with you here:

root      6151  0.0  0.0 1748148 22700 ?       Ssl  Aug24   0:23 /opt/bitnami/gonit/bin/gonit
bitnami  28898  0.0  0.0   6644  3184 ?        Ss   13:11   0:00 bash -c ps aux | grep gonit sudo cat /var/run/gonit.pid sudo gonit status sudo head -n10 /var/log/gonit.log
bitnami  28900  0.0  0.0   6208   824 ?        S    13:11   0:00 grep gonit
6151
Uptime                         160h15m30s
Last Check                     2021-08-31 13:10:13.333305595 +0000 UTC m=+576840.811492919
Next Check                     2021-08-31 13:12:13.333305595 +0000 UTC m=+576960.811492919
Pid                            6151
Pid File                       /var/run/gonit.pid
Control File                   /etc/gonit/gonitrc
Socket File                    /var/run/gonit.sock
Log File                       /var/log/gonit.log
Process 'apache'
  status                                        Running
  pid                                             19320
  uptime                                          8m19s
  monitoring status                           monitored

Process 'mariadb'
  status                                        Running
  pid                                             28751
  uptime                                          2m12s
  monitoring status                           monitored

Process 'php-fpm'
  status                                        Stopped
  uptime                                             0s
  monitoring status                           monitored
time="2021-06-18T14:45:16Z" level=info msg="Performing checks"
time="2021-06-18T14:45:16Z" level=info msg="Performing process check php-fpm"
time="2021-06-18T14:45:16Z" level=info msg="Performing process check apache"
time="2021-06-18T14:45:16Z" level=info msg="Performing process check mariadb"
time="2021-06-18T14:47:16Z" level=info msg="Performing checks"
time="2021-06-18T14:47:16Z" level=info msg="Performing process check apache"
time="2021-06-18T14:47:16Z" level=info msg="Performing process check mariadb"
time="2021-06-18T14:47:16Z" level=info msg="Performing process check php-fpm"
time="2021-06-18T14:49:16Z" level=info msg="Performing checks"
time="2021-06-18T14:49:16Z" level=info msg="Performing process check apache"
Cannot find any running daemon to contact. 
	If it is running, make sure you are pointing to the right pid file (/var/run/gonit.pid)
Warning: Custom redirections are not supported in the Bitnami WordPress 
Multisite Stack. This tool will not be able to enable/disable redirections.
total        used        free      shared  buff/cache   available
Mem:          63798         885       62626           9         285       62318
Swap:             0           0           0
Aug 31 13:15:23 ip-172-31-25-17 bitnami[29160]: php 13:15:23.07 ERROR ==> php-fpm did not start
Aug 31 13:15:23 ip-172-31-25-17 bitnami[29160]: 2021-08-31T13:15:23.075Z - error: Unable to perform start operation Export start for php failed with exit code 1
Aug 31 13:15:23 ip-172-31-25-17 bitnami[29160]: ## 2021-08-31 13:15:23+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/010_bitnami_agent_extra...
Aug 31 13:15:23 ip-172-31-25-17 bitnami[29160]: ## 2021-08-31 13:15:23+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/020_bitnami_agent...
Aug 31 13:15:23 ip-172-31-25-17 bitnami[29160]: ## 2021-08-31 13:15:23+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/030_update_welcome_file...
Aug 31 13:15:23 ip-172-31-25-17 bitnami[29160]: ## 2021-08-31 13:15:23+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/040_bitnami_credentials_file...
Aug 31 13:15:23 ip-172-31-25-17 bitnami[29160]: ## 2021-08-31 13:15:23+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/050_clean_metadata...
Aug 31 13:15:23 ip-172-31-25-17 systemd[1]: bitnami.service: Control process exited, code=exited, status=1/FAILURE
Aug 31 13:15:23 ip-172-31-25-17 systemd[1]: bitnami.service: Failed with result 'exit-code'.
Aug 31 13:15:23 ip-172-31-25-17 systemd[1]: Failed to start LSB: bitnami init script.

Does any of this help to find out what is going on?
Thanks,

Hello @alliancelsppc,

Please try to include the executed command every time you share the output of one, which will help everyone to better understand the related logs.

Regarding your gonit error, I suppose it appeared after running:

sudo /opt/bitnami/ctlscript.sh restart

Any issues with the daemon initialization should be solved with sudo gonit reload or sudo gonit. Please first restart the instance and then run execute these commands::

$ sudo gonit
daemon with PID 1558 awakened

If you get the following error

Socket file '/var/run/gonit.sock' is not writable

Remove that file:

sudo rm /var/run/gonit.sock

And try again:

sudo gonit

And check the status:

sudo /opt/bitnami/ctlscript.sh status

Apart from that, we will need to solve the issue of bnsupport-tool freezing, as without it we won’t be able to investigate any further issues properly. Plase try executing the following commands to download the latest version of our tool, which has now been renamed to bndiagnostic-tool:

wget -O bndiagnostic-linux-x64.run https://downloads.bitnami.com/files/bndiagnostic/latest/bndiagnostic-linux-x64.run
sudo mkdir /opt/bitnami/bndiagnostic
sudo mv bndiagnostic-linux-x64.run /opt/bitnami/bndiagnostic/
sudo chmod +x /opt/bitnami/bndiagnostic/bndiagnostic-linux-x64.run
sudo ln -s /opt/bitnami/bndiagnostic/bndiagnostic-linux-x64.run /opt/bitnami/bndiagnostic-tool
sudo /opt/bitnami/bndiagnostic-tool

If the tool execution freezes again or any of the previous commands fail, please share with us the output of the failed command.

Regards,
Francisco de Paz

Hello!
When running this commands, I got this message and it keeps loading forever:


Welcome to the Bitnami Diagnostic tool.


Please read the following information carefully.


Then, when running this:

sudo /opt/bitnami/ctlscript.sh status

apache already running
mariadb already running
php-fpm not running

I restored an older backup of the site, 'cause I couldnt wait, but it’s ‘running’ on other IP to try to fix it.
Thanks,

Hello @alliancelsppc,

That is really strange, could you verify that running sudo /opt/bitnami/bndiagnostic-tool doesn’t output the last Press [Enter] to continue: line?

I haven’t been able to reproduce the issue, could you tell me which is the version of your instance?

Regards,
Francisco de Paz

Hello!
I got this message when trying to run Diagnostic Tool:

Error copying file from packed archive /opt/bitnami/bndiagnostic/bndiagnostic-0.9.13-linux-x64.run to /tmp/autoupdater/update.ini
:Destination not writable

Hello @alliancelsppc,

The error is caused by not running bndiagnostic-tool with sudo as I detailed in my previous messages, which causes an error with insufficient permissions. Please rerun the tool with sudo and use the code ID to open a “Technical Issue” thread in case you need further help getting your instance running:

sudo /opt/bitnami/bndiagnostic-tool

Regards,
Francisco de Paz

Will do so. Thanks for your help!