Bitnami support errors

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Connectivity (SSH/FTP)
bnsupport ID: 92a0b7bb-9752-1161-effa-0a7b173dbf18
Description:
The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
92a0b7bb-9752-1161-effa-0a7b173dbf18

  Something when wrong while starting the services, Please run bnsupport and open a ticket at: https://community.bitnami.com Error   
  ocurred:exit status 8                                                                                                              
                                                                                                                                     
  /opt/bitnami/mysql/scripts/ctl.sh : mysql  started at port 3306                                                                    
  /opt/bitnami/php/scripts/ctl.sh : php-fpm started                                                                                  
  apache config test fails, aborting

Hi @cerelouise

Thanks for using Bitnami WordPress!

The bnsupport-tool has identified the following issues, could you please take a look at them?

? Apache: Found possible issues
? Resources: Found possible issues
✓ Mysql: No issues found
? Connectivity: Found possible issues
✓ Php: No issues found
? Wordpress: Found possible issues

[Apache]

The Apache configuration has errors:

AH00526: Syntax error on line 49 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf: SSLCertificateFile: file '/opt/bitnami/apache2/conf/astro-phys.space.crt' does not exist or is empty

Please check the configuration.

[Resources]

Your instance has little available RAM memory. total used free shared buff/cache available:

Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:            486         343           8           1         135          96
Swap:           634         122         512

You could try to increase your instance’s memory. Please check your cloud provider’s documentation for more information.

[Wordpress]

Some files don’t have the expected permissions Please check the following guide:

https://docs.bitnami.com/general/apps/wordpress/administration/understand-file-permissions/

The WordPress domain does not seem to be configured. Please check the following guide:

https://docs.bitnami.com/aws/apps/wordpress/administration/configure-domain/


From all these errors, the first one it high-likely the one preventing the service from starting. Nevertheless, you are running WordPress in an instance below the minimum required specs and this could also lead to errors. WordPress does require at least 700MB of RAM, but we usually recommend at least 1GB.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

So how are you getting this information, it keeps telling me the bitnami directory doesn’t exist

This is the information related to the bnsupport-tool id you provided.

it keeps telling me the bitnami directory doesn’t exist

Where do you see that error? What are the steps you follow to reproduce it?

Could you please run the following command and share the output?

ls -la /opt/bitnami

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

I have no idea what is going on with this, it was working well, then I didn’t check on it for like a week and this happens.

bitnami@ip-172-26-13-72:~$ ls -la /opt/bitnami
ls: cannot access ‘/opt/bitnami’: No such file or directory
bitnami@ip-172-26-13-72:~$

Hi @cerelouise

Back at the time when the bnsupport-tool was executed, it seemed like the /opt/bitnami directory was in place, and hence the tool was able to produce the report.

If the directory /opt/bitnami was removed, I am afraid that you will need to launch another instance and perform a restoration of your data using a backup. This directory basically contains all the applications and data (Apache, WordPress, PHP, …) so without it, the instance is a plain Debian machine.

Do you happen to have a backup of your data? In that case, you can follow one of our guides:
https://docs.bitnami.com/google/apps/wordpress/administration/backup-restore/

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Thank you Jose! I appreciate your help. Do you know how this could’ve happened? Like I said I didn’t do anything with it for a week and I suddenly couldn’t use it.

Thank you Jose! I appreciate your help.

My pleasure!

Do you know how this could’ve happened? Like I said I didn’t do anything with it for a week and I suddenly couldn’t use it.

Unfortunately, no. All the similar cases in the past were related to the user deleting the directory by mistake. Does someone else have access to your instance?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

No one else, does, it is possible I did something that removed it by mistake. I got a new instance up and thought i’d go iwth the mulit-instance since I’m considering one for personal blogging and one to share STEM things for people to learn (like my original one) and the mutlisite setup is crazy complex and way not enough documentation on it.

Hi @cerelouise

…the mutlisite setup is crazy complex and way not enough documentation on it.

I am sorry to hear that! We value feedback from our users, so it would be nice if you could let us know what you are missing in our documentation. We will be more than happy to evaluate that in order to improve :slightly_smiling_face:

In the same way, feel free to create a new thread if you experience any problem during your set up and we will try to help you out in the forum!

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

define(‘ADMIN_COOKIE_PATH’, ‘/’);
define(‘COOKIE_DOMAIN’, ‘’);
define(‘COOKIEPATH’, ‘’);
define(‘SITECOOKIEPATH’, ‘’);

Adding this to the wp-config.php file was an absolute must to get it started. It does not have the network settings the multisite should have and does not allow me to access plugins or themes or anything.

Hi @cerelouise

Adding this to the wp-config.php file was an absolute must to get it started. It does not have the network settings the multisite should have and does not allow me to access plugins or themes or anything.

According to the report generated by the bnsupport-tool, you are using the Bitnami WordPress Stack. If you are planning to work with the multisite version of WordPress, bitnami does offer a specific stack for that so you don’t have to adapt the single-site version yourself:

https://bitnami.com/stack/wordpress-multisite

Maybe you would like to give it a try :smiley:

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

You didn’t listen, I was on a single-site, after that was unable to be fixed, I switched to multisite, which shows multi site when I connect through SSH

Hi again,

It is true that you mentioned the possibility of using WordPress Multisite in your new instance, but I was unsure if you finally decided on it or not. In any case, my point was just to let know the existence of that solution :slightly_smiling_face:

does not allow me to access plugins or themes or anything.

I wasn’t able to reproduce your issue, but happy to help if you describe the steps for me to reproduce it on my side.

Additionally, here you have the associated documentation page for the stack, which covers a lot of common topics:
https://docs.bitnami.com/aws/apps/wordpress-multisite/

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.