Bitnami service start failure after installing SSL certificate with certbort

Keywords: Nginx - AWS - Technical issue - Other
bnsupport ID: ff48277c-e36b-958d-45cd-261183a5baf7
Description:
We are using an AWS bitnami EC2 instance for NGINX reverse proxy function. The server was working fine before. To add a site certificate, I followed the steps at https://tecnstuff.net/secure-nginx-with-lets-encrypt-on-debian-10/ . The certificate was installed successfully, but the Bitnami service is failing every time the server restart. Here is the error when running ‘systemctl status bitnami.service’:

bitnami[882]: nginx: [emerg] still could not bind()
bitnami[882]: 2021-02-28T05:18:50.461Z - error: Unable to perform start operation Export start for nginx failed with exit code 1
bitnami[882]: ## 2021-02-28 05:18:50+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/010_bitnami_agent_extra…
bitnami[882]: ## 2021-02-28 05:18:50+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/020_bitnami_agent…
bitnami[882]: ## 2021-02-28 05:18:50+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/030_update_welcome_file…
bitnami[882]: ## 2021-02-28 05:18:50+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/040_bitnami_credentials_file…
bitnami[882]: ## 2021-02-28 05:18:50+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/050_clean_metadata…
systemd[1]: bitnami.service: Control process exited, code=exited, status=1/FAILURE
systemd[1]: bitnami.service: Failed with result ‘exit-code’.
systemd[1]: Failed to start LSB: bitnami init script.

I just run the bnsupport-tool and the code is ff48277c-e36b-958d-45cd-261183a5baf7 . Please let me know the solution to fix it. Thanks.

Hi @samhao,

There seems to be another process running on port 80. Can you check which?

sudo netstat -tulpn | grep 80

Regards,
Michiel

Thank you very much for this.

I found out that the conflict was caused by python3-certbot-nginx. It enabled the nginx service from linux os, which caused conflict with bitnami nginx. It was resolved by using the follow command to disable the linux os nginx service:

sudo systemctl status nginx | grep running
sudo systemctl status nginx | grep enabled
sudo systemctl stop nginx
sudo systemctl disable nginx
sudo systemctl status nginx | grep disabled

Hi @samhao,

I’m glad to hear that you managed to solve the problem. As you mentioned, the NGINX system’s service must be stopped and disabled to be able to use the Bitnami NGINX service.

Enjoy :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.