Bitnami Redmine Fresh install not working

Keywords: Redmine - Virtual Machines - How to - Other

Description:
I’ve loaded up the bitnami 5.0.0-1 installer on my VM. Yet a fresh install is not working.
This is a VM without (and shouldn’t have) internet access.

Whenever i try to load it up, redmineThin1 could not be started.

I’m facing 3 errors while installing.

  1. MSYSpackage.bat failted to retrieved file, i undersand this is because i dont have any internet access, is this install crucial to hosting bitnami?

2)Ruby in Redmine.ini is failing to create the makefile for some reason, probably a lack of necessary libraries and/or headers.
The compiler failed to generate an executable file(RuntimeError)
You have to install development tools first

3)Problem in running post-install step. Installation may not complete correctly. Error running serviceinstall.bat INSTALL:The redmineThin1 service could not be started.
The service did not report an error
Net HELPMSG 3534 did not give any details as well.

This seems like it needs an internet connection to install said file, however, i am unable to provide an internet connection for this server.

Hi @dan.low,

Could you check the installation log for errors? You can find it in the user temp directory (enter %TEMP% in the file explorer). It’s named installbuilder.*.log.

Regards,
Michiel

Hi @michiel ,

Thanks for the quick reply.

It looks like a bunch of installation errors of the packages according to the installbuilder.log

I’m not able to upload the .log file, is there any other way for me to share it here?

Notable parts are:

D:\Redmine\msys64>pacman -U --noconfirm --needed “D:\Redmine\msys64\var\cache\pacman\pkg\autoconf-2.69-3-any.pkg.tar.xz”
loading packages…
resolving dependencies…
looking for conflicting packages…

Packages (2) m4-1.4.19-2 autoconf-2.69-3

Total Download Size: 0.23 MiB
Total Installed Size: 2.39 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages…
m4-1.4.19-2-x86_64 downloading…
Errors occurred, no packages were upgraded.

This is followed by a bunch of timeouts

D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/exe/bundle:37:in <top (required)>' D:/Redmine/ruby/bin/bundle:23:in load’
D:/Redmine/ruby/bin/bundle:23:in `’

An error occurred while installing strscan (3.0.1), and Bundler cannot continue.

In Gemfile:
net-imap was resolved to 0.2.3, which depends on
strscan
D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/definition.rb:496:in materialize': Could not find thin-1.8.0, strscan-3.0.1, rails-6.1.4.7, rouge-3.28.0, request_store-1.5.1, roadie-rails-3.0.0, rbpdf-1.20.1, rubyzip-2.3.2, net-smtp-0.3.1, net-imap-0.2.3, net-pop-0.1.1, tzinfo-data-1.2022.1, rotp-6.2.0, rqrcode-2.1.1, net-ldap-0.17.0, redcarpet-3.5.1, sanitize-6.0.0, sprockets-rails-3.4.2, roadie-5.0.0, rbpdf-font-1.19.1, rqrcode_core-1.2.0, sprockets-4.0.3 in any of the sources (Bundler::GemNotFound) from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/definition.rb:234:in specs_for’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/runtime.rb:18:in setup' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler.rb:149:in setup’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/setup.rb:20:in block in <top (required)>' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/ui/shell.rb:136:in with_level’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/ui/shell.rb:88:in silence' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/setup.rb:20:in <top (required)>’
from D:/Redmine/ruby/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require' from D:/Redmine/ruby/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require’
from bin/rake:27:in <main>' D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/definition.rb:496:in materialize’: Could not find thin-1.8.0, strscan-3.0.1, rails-6.1.4.7, rouge-3.28.0, request_store-1.5.1, roadie-rails-3.0.0, rbpdf-1.20.1, rubyzip-2.3.2, net-smtp-0.3.1, net-imap-0.2.3, net-pop-0.1.1, tzinfo-data-1.2022.1, rotp-6.2.0, rqrcode-2.1.1, net-ldap-0.17.0, redcarpet-3.5.1, sanitize-6.0.0, sprockets-rails-3.4.2, roadie-5.0.0, rbpdf-font-1.19.1, rqrcode_core-1.2.0, sprockets-4.0.3 in any of the sources (Bundler::GemNotFound)
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/definition.rb:234:in specs_for' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/runtime.rb:18:in setup’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler.rb:149:in setup' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/setup.rb:20:in block in <top (required)>’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/ui/shell.rb:136:in with_level' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/ui/shell.rb:88:in silence’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/setup.rb:20:in <top (required)>' from D:/Redmine/ruby/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require’
from D:/Redmine/ruby/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require' from bin/rake:27:in
D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/definition.rb:496:in materialize': Could not find thin-1.8.0, strscan-3.0.1, rails-6.1.4.7, rouge-3.28.0, request_store-1.5.1, roadie-rails-3.0.0, rbpdf-1.20.1, rubyzip-2.3.2, net-smtp-0.3.1, net-imap-0.2.3, net-pop-0.1.1, tzinfo-data-1.2022.1, rotp-6.2.0, rqrcode-2.1.1, net-ldap-0.17.0, redcarpet-3.5.1, sanitize-6.0.0, sprockets-rails-3.4.2, roadie-5.0.0, rbpdf-font-1.19.1, rqrcode_core-1.2.0, sprockets-4.0.3 in any of the sources (Bundler::GemNotFound) from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/definition.rb:234:in specs_for’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/runtime.rb:18:in setup' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler.rb:149:in setup’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/setup.rb:20:in block in <top (required)>' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/ui/shell.rb:136:in with_level’
from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/ui/shell.rb:88:in silence' from D:/Redmine/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.2.27/lib/bundler/setup.rb:20:in <top (required)>’
from D:/Redmine/ruby/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require' from D:/Redmine/ruby/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require’
from bin/rake:27:in `’

Error running D:\Redmine/apps/redmine\scripts\redmineini.bat : [DEPRECATED] The --path flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use bundle config set --local path 'vendor/bundle', and stop using this flag
[DEPRECATED] The --without flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use bundle config set --local without 'development test sqlite', and stop using this flag
[DEPRECATED] The --binstubs option will be removed in favor of bundle binstubs --all
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.


For the RedmineThin errors, not much is shown.

Script stderr:
The redmineThin1 (managed by WinServ) service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

The redmineThin2 (managed by WinServ) service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

Error running D:\Redmine/apps/redmine\scripts\serviceinstall.bat INSTALL: The redmineThin1 (managed by WinServ) service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

The redmineThin2 (managed by WinServ) service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

Problem running post-install step. Installation may not complete correctly
Error running D:\Redmine/apps/redmine\scripts\serviceinstall.bat INSTALL: The redmineThin1 (managed by WinServ) service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

The redmineThin2 (managed by WinServ) service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

Regards,
Dan

Hi @michiel ,

I’ve uploaded it onto pastebin herehttps://pastebin.com/XMfPUmq0

Hi @dan.low,

On which Windows version are you installing the application?

Regards,
Michiel

Hi @michiel , this version is windows server 2019

Hi @michiel,

Just pinging on this issue.

Regards,
Dan

Hi @michiel,

Just pinging on this issue. I am Dan Low friend.

Regards,
Leonard Tiong

Hi @leonardtiong,

Can you check the solution from this thread?

https://github.com/msys2/MSYS2-packages/issues/2529

Regards,
Michiel

The same error is occurring in Windows 10.

Hi @michiel,

I have installed MSYS2. But RedmineThin and RedmineThin 2services still cannot run.

Regards,
Leonard