Bitnami Redmine 3.3.0.0 Installation crashes

I downloaded bitnami-redmine-3.3.0.0-windows-installer. The OS is windows 2008 R2. After running install, even runas administrator, selecting subversion, phpmyadmin, redmine, and git, folder selection, creating admin account, selecting language, and when i click on next for ready to install, this is what i get.

Bitnami redmine stack has stopped working.
A problem caused the program to stop working correctly. Please close the program.

Any advise? thanks

Hi azshane,

I have met this installation crashed problem on “bitnami-redmine-3.2.3-1-windows-installer.exe” ,too.The appearence is also the same.My OS is windows7 x64 enterprise,I also tried on my colleague’s PC,all crashed.But when I copy the install package to my PC at home and do the installation,it success.

I wonder whether it has a relationship with my company’s network limitation during the installation.

I will pay attention to your issue.

Me too, 3.3.0 crashed

Hi everyone,
for me it is happening too with the version 3.3.0, I’m running W7 Professional SP1, and it crash when I it start installing, I have tried in another computer with similar configuration and it crash too. :worried:

Hello,
I have the exact same problem on windows 10 Family (64 bits).

I tried installing the ruby stack ( https://bitnami.com/stack/ruby/installer )
and then the redmine module ( https://bitnami.com/stack/ruby/modules#redmine )

So I choose ruby stack 2.2.5-3 and run the installation.
This installs a lot of stuff that I don’t need but well… I selected all.
And then the gems installation is soooo long (nearly 1 hour on my machine).

After that I tried installing the redmine module 3.3.0-0 and when, in the wizard, I selected the ruby stack installation folder : “C:\Bitnami\rubystack-2.2.5-3” I got this nice message :
“You are trying to install a Ruby 2.1.0 based application in a Bitnami stack that is not supported. Please download an install Ruby Stack 2.1.0 version at bitnami.com site”

Hum … okay
I give up for today.
Anyone with a better idea ?

Regards,
M

Actually, I didn’t give up…

I uninstalled the ruby stack version 2.2.5-3 and installed the 2.1.9-4 instead.
It took the same forever time…
But after that the redmine module installer didn’t complain.

I finally have a redmine installation working on my computer.

Few… I guess this is just a workaround for those who want to try redmine now.
I hope the bitnami team will make the redmine installer work…

Regards,
M

I did installed bitnami-rubstack-2.1.9.4-windows-installer installed on my Win2008R2 box which I am unable to install the redmine 3.3.x.x because if stack keeps stopping. I just installed rubstack 2.1.9.4 on a fresh win2008R2 box, then tried to install bitnami 3.3.x.x and same problem. Seems like an issue with installer not supporting win2008r2 or winx64.

Any bitnami support can add to this issue?

Hi,

It’s same probrem with Bitnami-redmine stack 3.3.0, Bitnami redmine with agile 3.3.0, and bitnami redmine stack 3.2.3 running on Windows 7 Proffesional SP1

Installer crashes when it start installing.
What’s happens?

I have same probrem too.
Win7 x64 Pro sp1

  • 3.3.0-0 NG
  • 3.2.3-1 NG
  • 3.2.3-0 OK
  • 3.2.0-0 OK

Any difference between 3.2.3-0 and 3.2.3-1 ?

Humm…
I may be wrong or missing something but you said that you installed ruby stack 2.1.9-4 correctly.
What did you install then ?
The redmine standalone version or the redmine ruby stack module ?
The first is available here : https://bitnami.com/stack/redmine/installer (195 MB)
The second one is here : https://bitnami.com/stack/ruby/modules (44 MB)

As the redmine standalone installer crashes, I installed the ruby stack (2.1.9-4) and then the redmine module (3.3.0-0).

I hope this will help.

Regards,
M

Seem nobody at Bitnami take care of this issue. Please hear us and check your new Redmine 3.3.0.0 Installation.

3.2.3-1 is crashes too. 3.2.3-0 is OK.
If you want to install Redmine 3.3, you should install Ruby stack then Redmine 3.3 module.

Yes, I successfully installed Redmine module 3.3.0-1 overwriting Redmine stack 3.2.3-0.
It runs well.

Are you sure, Bitnami don’t release 3.3.0-1 yet.

Hello,

We are unable to reproduce your issues with Redmine Stack. We were able to install without any problems the Redmine Stack 3.3.0-0.

However, the last Redmine Module 3.3.0-0 is running into problems (we are working to fix them) with the latest Ruby Stack version. This module is not prepared to work with the new Ruby Stack 2.2.5-3. Currently, you will have to install it using the Ruby Stack 2.1.9-4 and you should not have any problems.

Please note the differences between Redmine Stack and Redmine module. The Stack includes all the components that Redmine needs to work, but the module need te be built in top of a Ruby Stack which will be the one containing the components that Redmine needs.

You can obtain Redmine modules for Ruby Stack from:
https://bitnami.com/stack/ruby/modules

You can obtain Redmine Stack from:
https://bitnami.com/stack/redmine/installer

Best Regards,

Juan

@jariza I just downloaded the Bitnami Redmine 3.3.0.0, tried to install it on Windows Server 2012 and on my PC with Windows 10 and had the same error.

When I open the exe file it prompts me for configuration info (name, user, password, path, etc) at the end when I click install, it starts installing but after 5 seconds it crashes.

Will you guys be releasing a new installer?

Hi everyone,

Thanks for the report! We have been able to reproduce this issue in a few cases and we’re working on fixing it.

In the meantime, you could test out the virtual machine images (for VirtualBox, VMWare, Parallels…) while we fix this issue: https://bitnami.com/stack/redmine/virtual-machine

Let us know if you have any question.

Best regards,
Juan

So 3.3.0 is unusable on Windows 10 64 bit, and the 2.x installer completes without crashing, but the
redmine “thin server” services are crashing at startup with no logging output.

So basically the entire Bitnami redmine installer line (2.x and 3.x) just don’t work right now. This is pretty bad.

This is enough to make me cease recommending Bitnami as a way to run Redmine on Windows which is beginning to seem like a bad idea. I’ll give this a try again in six months and see if it’s still a pile of technical hurt.

Ouch!

Warren

Hi everyone,

We are happy to announce that we release a new revision of Redmine fixing the issue with Windows Installers. You should not have any problem to install Redmine 3.3.0 with these new installers. You can download Redime Stack from the following links:
https://downloads.bitnami.com/files/stacks/redmine/3.3.0-1/bitnami-redmine-3.3.0-1-windows-installer.exe

Sorry for the inconveniences.

Best Regards,

Juan

Thanks!.. I just downloaded it and it’s working ok.