Bitnami mysql binlogs taking upto 200 gb

Keywords: WordPress - AWS - How to - Application configuration

Description:
Lately my aws machine storage (/dev/xvda1) was filling up at a great pace and i found out lots of /opt/bitnami/mysql/data/binlog.XXXX files taking up 1 gb each . To which i found a solution that i should add expire_logs_days=3 to the mysql config.
Will doing that might break the website i have running on my machine in any way ?

Hi @vsr.bruh,

The binlog files store all the actions that are performed in the database and help you recover the database information in case something goes wrong. If you disable them, nothing won’t break. I suggest you disable the binlog configuration completely and configure the instance backups in AWS (that way you can recover the instance easily if something happens).

https://docs.bitnami.com/aws/infrastructure/mysql/troubleshooting/disable-binary-logging-mysql/
https://docs.bitnami.com/aws/faq/administration/backup-restore-server/

Happy to help!


Was my answer helpful? Click on :heart:

I was able to clear some binlog files but recently they are back (around 20+ files) even after specfying expire_logs_days = 4…
also i was curious about some other files which are above 60+ gb in size
eg : /opt/bitnami/apps/wordpress/htdocs/wp-content/updraft/backup_2021-11-21-1959_XXXXXX_4cb
c05a6cd16-db.gz [65gb ]
and /opt/bitnami/mysql/data/bitnami_wordpress/wp_wpr_rucss_resources.ibd [ 110gb ].
so is there we can do anything to reduce the storage being consumed.

Hello @vsr.bruh,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.