Bitnami Moodle 3.9.2-0 on Debian 10 image on AMI; application is not available

Keywords: Moodle - AWS - Technical issue - Other
Description:
Detailed steps I took to get to my present situation:

  1. Create AWS account
  2. Bitnami Moodle 3.9.2-0 on Debian 10 image on AMI
  3. Launch EC2 instance
  4. Unable to access the Moodle server

I tried to run the Bitnami Support Tool according to these instructions, but I cannot even ssh into this AMI (when I try, following these instructions, ssh times out). The EC2 AMI is running though, so I’m not sure why I cannot access either sshd or Moodle in this AMI.

I’ve had a support query out to AWS for this same problem for the past 24 hours or so.

I think I’m getting billed by the hour, so just want to try to resolve this as quickly as possible.

Below is a copy of my most recent update to my trouble ticket with AWS:

I think I may have figured out the root cause of this problem.

Looking at (link removed because I’m too new to have more than 2 links in a post) , I see:

"EC2 Instance Connect
Instance ID: i-0ab632cee3fc88c71
Public IP address: 3.237.14.14
User name: admin
Connect using a custom user name, or use the default user name admin for the AMI used to launch the instance.

Note: In most cases, the guessed user name is correct. However, read your AMI usage instructions to check if the AMI owner has changed the default AMI user name."

But when I click the next tab (Session Manager), I see:

"We weren’t able to connect to your instance. Common reasons for this include:

SSM Agent isn't installed on the instance. You can install the agent on both Windows instances and Linux instances.
The required IAM instance profile isn't attached to the instance. You can attach a profile using AWS Systems Manager Quick Setup.
Session Manager setup is incomplete. For more information, see Session Manager Prerequisites.

Session Manager usage:
Connect to your instance without SSH keys or a bastion host.
Sessions are secured using an AWS Key Management Service key.
You can log session commands and details in an Amazon S3 bucket or CloudWatch Logs log group.
Configure sessions on the Session Manager Preferences page."

So I looked at Session Manager Prerequisites at (link removed because I’m too new to have more than 2 links in a post) and it’s not clear that this Bitnami image has all these prerequisites.

In any case, the instructions for using this Bitnami image (which make it sound so simple to set up, with just a single click of a button, and that’s why I subscribed to it) are not working for me.

So I need some assistance, and the email I received from Bitnami which opens with:

"Dear AWS Marketplace Customer,

Thank you for selecting the Bitnami Moodle Certified by Bitnami image on AWS Marketplace!.."

closes by referring me as follows "If you have any questions, please reach out to the AWS Marketplace Customer Service team at: (link removed because I’m too new to have more than 2 links in a post) ", and that leads to this support center, so it looks like I’m pursuing corrective action for this problem in the manner that is prescribed by the welcome to AWS Marketplace Customer Service team.

I’m hoping to receive a discount on the fees I’m paying due to the non-availability of the instance.

And I still cannot to my instance.

Could someone please advise me on next steps. I have already done the Quick Setup at (link removed because I’m too new to have more than 2 links in a post) and connected this profile to all instances. I even rebooted my instance in case that was required after doing the Quick Setup, but I’m still not able to connect to my instance.

So can someone please advise me on resolving this problem?

Thanks for any suggestions from the community!

Hi @KevinFordSubmariner,

Did you check this guide https://docs.bitnami.com/aws/faq/get-started/connect-ssh/?

If you get an error, please copy in the thread.

Regards,
Ibone.

1 Like

Hi @Ibone and thanks for your quick reply and the link.

Yes, I did see that guide, and unfortunately, the instructions in it are not generating for me the results that are described in the guide.

When I try to ssh into the AMI using the public IP address listed in AWS Console for this instance, I see no errors; instead, the ssh client on my localhost just times out. Pinging the public IP address generates no responses either, but I’ve confirmed in AWS Console that the instance is running. I used AWS to generate the keypair and I downloaded it and installed on localhost, but the IP address itself is not answering, so based on that, it seems like an AWS issue, not a bitnami issue.

However, the “common reasons” listed above (which include “SSM Agent isn’t installed on the instance.”) cause me to believe that the problem could also be associated with the bitnami image. And another possibility (“The required IAM instance profile isn’t attached to the instance.” is something that I think I resolved using the Quick Setup and I attached the IAM instance profile to the instance, but despite my having done that, my instance is not appearing in the list of available instances in the Session Manager, so I’m currently at a loss to understand this.

AWS has replied to my trouble ticket, but not with anything I can take action on, so I’m still just waiting for a solution from bitnami and/or AWS with some technical instructions that I can use to try to continue troubleshooting this problem.

Thanks again for your quick reply.

Kind regards,
Kevin Ford The Submariner
http://kevin.ford.みんな

Hi @KevinFordSubmariner,

The instance performance it’s too slow. Did you try to restart the instance, and after the instance is available to connect to it?

Regards,
Ibone.

1 Like

Yes, I did reboot it at least once, and after it was running again, the behavior was the same.

Moments ago, however, I terminated the instance at the recommendation of AWS Support, so this problem for this particular instance has been resolved by me terminating the instance, but the root cause (that I imagine would affect anyone who attempts to use https://aws.amazon.com/marketplace/pp/prodview-4vrsnatvdabsc?productId=2a07b755-1c35-4fc7-88ce-c6d01b3cae06 like I did) is probably still there, waiting for someone else to encounter it.

I’m still trying to figure out the relationship between AWS and Bitnami for this AWS Marketplace product/service/subscription. AWS Support told me that it is offered at no charge (free) by Bitnami, and that the only fees are those associated with the AWS EC2 instance.

If that is the case, can you help me understand what Bitnami gets out of packaging Moodle for one-click deployment on AWS? I mean, the advertising makes it seem very desirable. I wanted to at least try it out. But my experience indicates that there may be a bit of misleading advertising in the claim. I’m pretty sure I read and correctly implemented all the instructions I encountered. If that is correct, then many things are still not clear to me:

  1. Why would Bitnami do this without compensation?
  2. Or does Bitnami receive (from AWS) a fraction of my payments to AWS?
  3. For the root problem I encountered, is it a problem with AWS or with the software packaged by Bitnami or perhaps both?
  4. Does Bitnami offer commercial support for products/services/subscriptions like this, or only community support via this discussion forum?

Any thoughts you can share on these questions would be most welcome.

And thanks again for your quick replies in this thread! :smiley:

Kind regards,
Kevin Ford The Submariner
http://kevin.ford.みんな

Hi @KevinFordSubmariner,

Bitnami are a partner of the could providers

Maybe there is a problem with some configuration of the instance like the ports https://docs.bitnami.com/aws/how-to/troubleshoot-ssh-issues/

No, only in the community.

I hope that resolves your doubts,
regards,
Ibone.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.