Bitnami modules working for standalone install?

Keywords: Moodle - Linux - How to - Other
Description:
I have a standalone Ubuntu server 20.04 LTS that runs XAMPP 7.4.11-0. I was excited to find out about all of the Bitnami modules, but when I installed the Moodle Bitnami module, it made a huge mess, copying the doc root over again into the Moodle folder. I just tried to install the Wordpress Bitnami module and the wp-* files are not in the doc root. I’m beginning to think these Bitnami modules do not work for standalone installs.

I found the Wordpress install under /opt/lampp/apps/wordpress/htdocs. However, the web root is: /opt/lampp/htdocs so how is that supposed to work. If I use a local browser and type local/wp-admin, I get errors. The Bitnami module didn’t get me a choice where to make the web root. Moodle did the same thing. For example, I would like Moodle to be a directory of the web root: /opt/lampp/htdocs/moodle. When I go through Moodle setup, I’m not given the chance to change the path. I guess I could go through the Moodle config.php file and edit. Gaah! How do these Bitnami modules make it easy again?

OK, never mind. I figured it out. Bitnami modules make their own pseudo doc root, so localhost/wordpress/wp-admin.
This is explained in the documentation.

Hi @coldje,

Thanks for using Bitnami. Yes, the modules are installed as prefixed applications, so http://localhost/wordpress should show your WordPress website, and http://localhost/moodle would show Moodle.

Did you also figure out the issue with the Moodle installation? Can you give us more information about this?

Hi gongomgra,

Thank you for your response. When I run the Bitnami Moodle install and allow it to install at the default /opt/moodle-3.10.0-0 During the install at the end, it throws an error. See uploaded pix. Moodle will begin the configuration routine using http://localhost:81/moodle, but gets to the point where it’s supposed to communicate with the database. “Error: Database connection failed. The site administrator should check that the database details have been correctly specified in config.php.”

I open config.php and dbuser/password listed is bn_moodle:f86ee42136 which is not in phpmyadmin. So the post-install step was creating the database, dbuser, etc. I create the database, etc via phpmyadmin. Restart mysql. Try it again. Same error.

The Bitnami Wordpress install was as smooth as silk. This is a giant mess. I’m wondering if I shouldn’t just DL the moodle zip and do a conventional install?

Update: I’ve figured out that the PHP file not able to be read, install.php, just creates the moodle config.php file. The install.php file will only run if the config.php file does not exist.
Hmm…so why if I directly edit the config.php in moodle to reflect the actual name of the db file, dbuser/password, etc. does it still hang up? More testing is required.

Hi @coldje,

Thanks for the screenshot. It looks like you are installing the full Bitnami Moodle Stack instead of the Bitnami Moodle Module. In that installation, I think the issue is that you are using a quotation mark for the shortname that is being missunderstood by the installation process. Can you try using a different shortname like drcoldsmoodlesite?

Installing the stack instead of the module also explains why Moodle is accessible on port 81 instead of 80. It installs the whole stack (Moodle app + required components like Apache, PHP, MySQL). As there is an Apache service running on port 80 (the one from XAMPP), it prompt you for a different port during the installation process.

OK, I like that answer. I didn’t know there was a difference between the stack and module versions. This is going to help quite a bit. Yeah, I don’t want the stack. More learning is required. Thank you for pointing me in the right direction.

When I go here: https://bitnami.com/download/files/stacks/moodle/3.10.0-0/bitnami-moodle-3.10.0-0-linux-x64-installer.run, that has to be the Bitnami Moodle Stack. Is there a different DL for the Bitnami Moodle Module? The .run file doesn’t say if it’s a stack or module.

Hi @coldje,

Yes, the download link you shared is the one for the Moodle stack. You can get the Moodle module to be installed on top of XAMPP from the next link

https://bitnami.com/stack/xampp

Thank you. I see the word “module” in the filename now. I am getting an error I’ve seen before: "Problem running post-install step. Installation may not complete correctly. Error running /opt/lampp/binphp. “/opt/lampp/apps/moodle/htdocs/admin/cli/install.php”

If I remember correctly, this just sets values in the Moodle config.php file. I will see if I can edit manually.

Hi @coldje,

I see you are installing Moodle on top of XAMPP 7.4. I’m not really sure if Moodle supports that version of PHP (https://docs.moodle.org/310/en/PHP) so that’s probably the issue. You will probably need to use XAMPP 7.3 or the Bitnami Moodle Stack in your computer to use Moodle in your system.

Thank you for your response. It’s fixed now. I was trying to edit the wrong config.php file. The correct file is located in: /opt/lampp/apps/moodle/htdocs/config.php. Sidenote: The moodle database that the script created did not have the correct collation. I ended up using phpmyadmin to delete the bitnami_moodle db and recreated another with the same name, this time with the collation utf8mb4_unicode_ci. I finished with granting bn_user all access to that db under localhost and 127.0.0.1.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.