Bitnami Installations Using System Packages Breaking Paths, Causing 404 in Plugins

Keywords: WordPress - AWS - Technical issue - Other
Description:
I’ve created a new website and installed new theme/plugins, but sometimes its breaking the page because now the wp-content folder is actually not within the wordpress folder where all the other files are (root/opt/bitnami/wordpress/), but instead is somewhere else, and wp-content folder inside the /opt/bitnami/wordpress folder is actually a symlink to the wp-content folder that’s in root/bitnami/wordpress/wp-content

Now some of the assets that are being used in a plugin is referencing

http://www.domain.com/wp-content/bitnami/wordpress/wp-content/plugins/...

instead it should be like:

http://www.domain.com/wp-content/plugins/...

removing /wp-content/bitnami/wordpress/

Hi @anrew,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Hello, thank you for the quick reply.

Here’s the code: d2c167a9-4271-d2e3-d517-fa529fb5ad56

Although, I do see an error saying that was coming out for Apache, but not sure if its related to the same error as not having the same path in one of my pages.

Thank you!

Hi @anrew,

Thanks for the bnsupport code. WordPress should work fine with the symlink for the wp-content folder. Can you tell us where do you see those wrong URLs? Which plugin is giving you the error? Can you check in the plugin configuration if there is any option to fix it?

We also recommend you to check with the plugins developers on how to get more information for this issue. Unfortunately, we can’t get any information from the Apache logs

Hello, thanks for continuous help.

I reached out to the developers, they’re saying that “It’s happening because AWS doesn’t provide correct url structure for wordpress. It’s not issue of theme options and you can’t fix this in theme options… You can set proper url for WP Content constant WP_CONTENT_DIR, WP_CONTENT_URL, WP_SITEURL, WP_HOME”

They pointed me to https://wpmudev.com/blog/change-wordpress-file-directory-structure/

Not sure if this is the correct path in fixing the actual issue? I’m only seeing the wrong URLs in the theme option page. This is where the theme has additional options that I can work with. The theme I’m working with is here: https://themeforest.net/item/rehub-directory-multi-vendor-shop-coupon-affiliate-theme/7646339

Hi @anrew,

Thanks for your message. Unfortunately, you are using a paid theme and we can’t test it. As you are having issues with a very specific URL for your custom theme, we recommend you to follow the theme’s developers suggestions on how to fix it and continue debugging the issue with them.

Regards,
Gonzalo

Hello @gongomgra, is it possible to manually set the type of structure? I think the older structure directory worked because I have multiple sites with this theme and it works fine.

I was wondering how I can do that?

Hello,

Just wanted to say that I fixed the issue.

I had to define WP_CONTENT_DIR, WP_CONTENT_URL.

Maybe if you come across this, you can let them know.

Thanks

Hi @anrew,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.