Bitnami 8.1.1-4 Stack running extremely slowly

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Upgrade

bnsupport ID: fb073851-ddb3-e6aa-ab76-f6f7aa8d3c1b

bndiagnostic output:

? Connectivity: Found possible issues
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: The information was incorrect, see above.

Description:
I just set up this new t3a.medium instance on AWS and I’m in the process of migrating websites from a previous server of exactly the same type. The only difference between the two instances is that the newer one has 10GB less EBS storage. When I log into the new instance using PuTTY (latest version), I type a command and can count to 10 before the CLI responds. The AWS monitoring says I’m using only 2% of memory, but trying to run any commands takes much longer on this instance than on my old one running LAMP 7.3.14-0.

  1. Is it because this new stack has MySQL 8 and PHP 8? If so, how much memory will the stack need to run 14-20 Joomla sites effectively?
  2. When I set up a new instance for a client, moving from MySQL 5.7 to MySQL 8, we had a nightmare trying to calm MySQL down – it was doing excessive logging. I haven’t even loaded the databases on the new instance, so is it MySQL that’s causing my problem?
  3. Your diagnostic tool thought I hadn’t opened ports 22, 80, and 443, but I’m using the identical AWS Security Group as with the old instance, and those ports are already open.

Should I kill this new instance and start over? I’m really flummoxed, worrying that the new instance with the same type will be insufficient to run my 20 or so Joomla websites.

Please advise.

You have a lot of available memory in the instance and there shouldn’t be any performance issue

-----------------------------------
Display amount of free and used memory in the system
-----------------------------------
Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:           3901         630         955          10        2315        2977
Swap:             0           0           0

There shouldn’t be any problem with MySQL and PHP according to the memory the different processes are using. However, there are many PHP processes and maybe you do not need that amount of processes. You can decrease them by following this guide

https://docs.bitnami.com/aws/apps/wordpress/configuration/configure-phpfpm-processes/

Regarding the amount of memory for those 14-20 sites, that’s something you will need to ask the Joomla’s developers to know more about that.

MariaDB is only using 83MB of RAM

83356 /opt/bitnami/mariadb/sbin/mysqld

There probably was a problem with the connectivity when executing the tool and that’s why the tool warned you about it.

You shouldn’t have problems with this new instance apart from configuring the number of processes to use.

Thank you Jota for your prompt response.

  • Right now none of the websites are running – I’m still copying files, so it makes sense that there would be a lot of free memory.
  • I have not loaded the databases so MySQL isn’t using as much memory as it will.
  • I’m not sure whether having a lot of available PHP processes helps run the Joomla sites more efficiently; I cannot know that until I start them up, and I don’t want to waste my time on an inadequate instance.

I dislike the fact that the CLI is already operating so slowly that it’s delaying my ability to even copy the files, let alone run them. I have 2 months left on a reserved instance for this size, so I will crunch the numbers to see whether it make sense to wait until the RI expires and get a bigger instance then, or launch a bigger instance now and get this over with.

Have my replies changed anything you would advise?

Anything else, Jota?

Hi @Toolie,

Checking the data the Diagnostic Tool provided, I do not see any problem. You have enough RAM memory and the command line shouldn’t run slow.

Can you run the top command and paste the output here? If the CPU/RAM usage is low, maybe there is a problem with the disk the instance is using and in that case, the Lightsail support team should provide more information about how to troubleshoot it.

I gave up on trying to make the instance work; I’ve concluded that I need the next larger instance, which unfortunately costs twice as much. When I launched your stack on the bigger instance and tried accessing it on PuTTY, the CLI behaved as I expected: immediate and peppy responses.

Feel free to try launching the stack on a t3a.medium and see whether you experience the same thing I did. https://bitnami.com/redirect/to/1897435/lampstack-8.1.1-8-amidebian-x64-hvm-ebs-nami?region=us-west-2

Otherwise, we can close this request as not resolved.

Hi @Toolie,

I just launched the same image in a different region and didn’t find any issue

bitnami@ip-172-31-41-107:~$ time cp bitnami_credentials bitnami_credentials.back

real	0m0.001s
user	0m0.001s
sys	0m0.000s
bitnami@ip-172-31-41-107:~$ top | head -n 5
top - 10:11:38 up 3 min,  1 user,  load average: 0.29, 0.24, 0.09
Tasks: 126 total,   1 running, 125 sleeping,   0 stopped,   0 zombie
%Cpu(s):  0.0 us,  0.0 sy,  0.0 ni,100.0 id,  0.0 wa,  0.0 hi,  0.0 si,  0.0 st
MiB Mem :   3901.3 total,   3167.8 free,    329.2 used,    404.2 buff/cache
MiB Swap:      0.0 total,      0.0 free,      0.0 used.   3346.8 avail Mem
bitnami@ip-172-31-41-107:~$ free -m
              total        used        free      shared  buff/cache   available
Mem:           3901         329        3167          10         404        3346
Swap:             0           0           0

I understand you ran into an issue with the AWS infrastructure and that’s why they all were solved when launching a new instance.

Happy to help!


Was my answer helpful? Click on :heart:

No you misunderstand: I did not try the SAME sized instance, I used a LARGER instance and got better results.

Hi @Toolie,

Yes, I understood. Please note that if you modify the instance type, the resources are “moved” to a different place where they can be allocated so you are basically using a different hardware. I think the previous hardware had some issues and everything were resolved when you modified the resources. I’m glad to hear that everything works fine now.

Thank you, I am aware that I am moving from one type of hardware to another. I guess I need your definition of “resources;” are you talking about the contents of the old server (instance)? If by resources you mean I altered settings in either instance, I did not. I made no changes to the PHP processes.

Jota my concern is that there is something wrong with the stack setting itself. I rely entirely on Bitnami to get that right, and you’ve always come though. Meanwhile I am using the larger (t3a.large) instance in hopes that everything will run smoothly.

No, the resources I’m referring to is the hardware you are using in the AWS cloud platform. Please note that those performance issues can also happen there. If you modify the instance, you will be using different hardware from that time on and that solves the problem .

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.