AWS Lightsail Drupal 9.1 from Bitnami error configure SMTP for outgoing mail

Keywords: Drupal - AWS - Technical issue - Email configuration (SMTP)

bnsupport ID: 8f27d7a5-f104-45f4-59cf-d66cafb2679f

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I have created a Bitnami Drupal 9 instance through AWS Lightsail. Went through the SMTP setup instruction for sending emails for a Contact Us form for the site: ttps://docs.bitnami.com/bch/apps/drupal/configuration/configure-smtp/. When testing send mail, keep getting SMTP error “Error sending e-mail” was set up as a valid authenticated email address on gmail.

Is this an AWS restriction? How to overcome?

Thanks!

Hi @leestert,

Could you run the bnsupport tool again with –runSMTPTool 1?

sudo /opt/bitnami/bnsupport-tool --runSMTPTool 1

This will give us more information about the SMTP issue.

Regards,
Michiel

9556eebb-71b8-0426-8602-58e0f7639fa3

Just ran your command. See the support handle. Thanks Michiel!

Hi @leestert,

The SMTP tool didn’t detect any errors. Did you receive a test mail? Did you follow these steps to configure SMTP:

https://docs.bitnami.com/installer/apps/drupal/configuration/configure-smtp/

Regards,
Michiel

Michiel, thanks again for checking. I’m new on this, please bear with me…

In case I missed anything, I did a fresh instance from AWS Lightsail Drupal with the following step:

  1. Created the Lightsail drupal 9.1 instance.
  2. Upgrade the drupal to 9.2.2.
  3. I couldn’t follow the “load the Bitnami stack environment” step because the bitnami install doesn’t have ./use_drupal script anywhere (could this be the problem). So I skipped this.
  4. Installed the phpmailer module as instructed.
  5. Enter the SMTP parameters as instructed - used zoho smtp server this time (used my zoho account user and pwd for SMTP authentication).
  6. Skip the SMTP client settings (left them blank).
  7. Entered a test mail recipient.
  8. Saved and got an on-screen error from the drupal SMTP configuration page.
  9. Checked log on linux server with “drush ws” which seem to say there is an authentication error.
  10. Ran the bitnami support command you give me. Didn’t register new errors in the log, but I didn’t receive any emails from the recipient mailbox.

Here is the new support string: 29083414-d531-ed71-a6e6-7a7bbad03321

I have a log file but cannot load it because i’m new user here:(

Hi @leestert,

I’ve reproduced the issue. A colleague from another team will help you further.

Regards,
Michiel

Michiel, thanks for confirming and following up.

Hi @leestert,

In your data of bnsupport appears that you get an error 535 Authentication Failed
I found this documentation of Zoho to configure the SMTP server.
On that page appears:

Authentication Failure
When configuring SMTP/ Outgoing Server, you need to provide the entire email address and the correct password for authentication. You may require an Application-specific Password to set up the account in other devices if you’ve enabled Two-Factor Authentication.

I think maybe this is related to your issue, have you enabled two-factor authentication?

Hi Ibone,

Application-specific Password was it! I was able to send emails. You’re the best!

Thanks, Lee

1 Like

Hi @leestert,

I’m glad the problem is solved. Closing this out now, do not hesitate to write us back if you have any other questions.