AWS Bitnami Lightsail: How to downgrade default Cakephp framework to 2.4.x?

Keywords: LAMP/MAMP/WAMP - AWS - How to - Plugins installation/configuration

Description:
I have successfully deployed a Lightsail LAMP 7.x Bitnami package and proceeded to downgrade the default php7.4 to 5.6. I am running a legacy app that runs on php5.6 with CakePHP 2.4x. I would like to downgrade the default CakePHP 4.x included down to 2.4.x Is there anyway to do this? This is the last hurdle I am trying to resolve before my web can deploy. Any help would be greatly appreciate it

Hi @ddGuy

Thanks for using Bitnami LAMP!

Unfortunately, we don’t have a guide that covers how to downgrade CakePHP. However, based on this stackoverflow issue, it just seems to be a matter of:

$ composer require cakephp/cakephp:"~2.4.0"

You can give it a try just in case and report back :slightly_smiling_face:

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

1 Like

It worked. Thanks you!! :slightly_smiling_face:

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: