Apache2 not running

Keywords: LAPP/MAPP/WAPP - AWS - Technical issue - Permissions
bnsupport ID: 19255064-14b7-ce33-8fcf-20532617a583
Description:
The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:

19255064-14b7-ce33-8fcf-20532617a583

And paste it in your Bitnami Support ticket.

Hi @macjobhk,

Thanks for using Bitnami. According to the bnsupport bundle, your server is running out of free memory available, and it is preventing new processes to be started

-----------------------------------
Display amount of free and used memory in the system
-----------------------------------
Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:            987         632          75           3         279         198
Swap:           634          19         615

The tool detected the next situations in your server that can cause errors. Can you check the recommended links to try to fix it?

? Apache: Found possible issues
? WordPress: Found possible issues
? Resources: Found possible issues
✓ Database: No issues found
  1. Found recent Pagespeed related error messages in the Apache error log:
[Thu Mar 11 15:09:08.674350 2021] [pagespeed:error] [pid 28829:tid 139768662796032] [mod_pagespeed 1.13.35.2-0 @28829] PageSpeed Serf fetch failure rate extremely high; only 0 of 38 recent fetches fully successful; is fetching working?

We suggest disabling pagespeed and check if that improves the behavior. Please check the following guide to disable Pagespeed:

https://docs.bitnami.com/general/apps/wordpress/administration/use-pagespeed/#disable-pagespeed

  1. Found recent error messages in the Apache error log.
[Wed Mar 10 17:12:51.004942 2021] [proxy_fcgi:error] [pid 19546:tid 139769325360896] (-102)Unknown error -102: [client 157.245.176.143:37374] AH01075: Error dispatching request to : (reading input brigade)

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

  1. The Apache configuration has errors:
httpd.bin: Syntax error on line 562 of /opt/bitnami/apache2/conf/httpd.conf: Could not open configuration file /opt/bitnami/apache2/conf/bitnami/bitnami.conf: No such file or directory

Please check the configuration.

  1. Some files don’t have the expected permissions Please check the following guide:

https://docs.bitnami.com/general/apps/wordpress/administration/understand-file-permissions/

  1. Your instance has little available RAM memory.
              total        used        free      shared  buff/cache   available
Mem:            987         634          68           3         284         193
Swap:           634          15         619

thank for support!
But the system said apache2 not running

How to solve it

I already disable the page speed

How to enable apache2 again?

Hi, l really dono how to fix the permission issue. pls help

Hi @macjobhk,

In the provided link, you have the needed information to understand the permissions issue and how to fix them. Just remember to replace TARGET with /opt/bitnami/apps/wordpress/htdocs, as this is the directory where your application is really installed.