Apache won't start after letsencrypt domain renewal

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: f416a0a1-d350-98c9-55e0-a0ccb98a79c7

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: The documentation did not make any significant change

Description:
Hi, yesterday when I tried to renew my domains using the bncert-tool, it failed mid-process. Unfortunately I missed to note the error message as it was a bit long. After that, apache won’t start.
When I try the command “sudo /opt/bitnami/bncert-tool”, it now tries to find the bitnami installation directory and if I hit enter to accept default, it shows this error – “AH00534: httpd: Configuration error: No MPM loaded.”
Also, when I try the command “sudo /opt/bitnami/ctlscript.sh status” it says “Cannot find any running daemon to contact. If it is running, make sure you are pointing to the right pid file (/var/run/gonit.pid)”.
Any help would be much appreciated, thank you!

Hi @ubay25,

Thanks for using Bitnami. Please note the bncert-tool is not intended to renew the SSL certificate, but the lego tool itself is in charge of doing so. I see you have a cronjob configure to renew it. Do you know if it found any error?

Apart from that, I see you don’t have any information in your /opt/bitnami/apache2/conf/httpd.conf file, and I think this must be preventing Apache to start. Can you recover the most recent one running the next command and try to start the services again?

sudo cp /opt/bitnami/apache2/conf/httpd.conf.back.202111211554 /opt/bitnami/apache2/conf/httpd.conf

I also see your server is running out of free memory to start new processes

-----------------------------------
Display amount of free and used memory in the system
-----------------------------------
Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:            983         430          92           7         460         367
Swap:           634          55         579

Can you try using a bigger instance?

https://docs.bitnami.com/aws/faq/administration/change-server-type/

1 Like

Thanks for your reply.
Recovering the httpd.conf did the trick and now it’s back to normal. Thank you very much!

Hi @ubay25,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.