Apache server Not starting in Reportserver local setup - server certificate does NOT include an ID which matches the server name

During installation of the Report server, I get error as - Problem running post-install step. Installation may not complete correctly Error reading file.

image

Error upon start of the server.

[Wed Sep 20 11:11:42.279880 2017] [ssl:warn] [pid 3388:tid 560] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 20 11:11:42.373639 2017] [ssl:warn] [pid 3388:tid 560] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 20 11:11:42.373639 2017] [mpm_winnt:notice] [pid 3388:tid 560] AH00455: Apache/2.4.27 (Win64) OpenSSL/1.0.2l configured – resuming normal operations
[Wed Sep 20 11:11:42.373639 2017] [mpm_winnt:notice] [pid 3388:tid 560] AH00456: Apache Lounge VC11 Server built: Jul 10 2017 14:15:02
[Wed Sep 20 11:11:42.373639 2017] [core:notice] [pid 3388:tid 560] AH00094: Command line: ‘C:\Bitnami\REPORT~1.2-7\apache2\bin\httpd.exe -d C:/Bitnami/reportserver-3.0.2-7/apache2 -f C:\Bitnami\REPORT~1.2-7\apache2\conf\httpd.conf’
[Wed Sep 20 11:11:42.373639 2017] [mpm_winnt:notice] [pid 3388:tid 560] AH00418: Parent: Created child process 2908
[Wed Sep 20 11:11:42.592414 2017] [ssl:warn] [pid 2908:tid 472] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 20 11:11:42.670550 2017] [ssl:warn] [pid 2908:tid 472] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 20 11:11:42.670550 2017] [mpm_winnt:notice] [pid 2908:tid 472] AH00354: Child: Starting 64 worker threads.

Hi @rairakesh,

Thank you for using Bitnami. Could you please let us know more information about the installation?

  • Which Operating System do you have? Which version?
  • What are the specifications of the machine? Please note that ReportServer requires more than 3Gb of RAM to work properly.
  • Did you have any other Bitnami stack installed in the system?
  • Could you please share with us the content of the installation log? You will find a bitrock_installer.log file at the %TEMP% directory. Please note that it’s a temporary directory and it’s removed when stopping or restarting the machine.

Regards,
Jota

Which Operating System do you have? Which version? - Windows 10 Pro

What are the specifications of the machine? Please note that ReportServer requires more than 3Gb of RAM to work properly. - Memory is 16 GB, System type is 64 Bit Operating system, x64 Based Processor.

Manufacturer of machine is - Lenevo, Model is - Thinkpad P51s Signature Edition.

Did you have any other Bitnami stack installed in the system? - No

Could you please share with us the content of the installation log? You will find a bitrock_installer.log file at the %TEMP% directory. Please note that it’s a temporary directory and it’s removed when stopping or restarting the machine. - I could not find bitrock_installer.log file at all, there is no temp directory. As per your notes have made sure server is up and running and there is no file called bitrock_installer.log

Other points I thought might be important for you is there are no log files under C:\Bitnami\reportserver-3.0.2-7\apache-tomcat\logs folder.

Found solution for Bitnami Report server 404 error

  1. If the user has already installed tomcat and has entry in the path as Catalina home, first you remove that entry from the path and environment variable.

  2. Rename your existing tomcat folder temporarily (That you might have installed in the past, do not rename C:\Bitnami\reportserver-3.0.2-7\apache-tomcat)

  3. Uninstall Bitnami report server and delete all files under /Bitnami folder

  4. Restart your laptop / desktop / Windows OS

  5. Re install Bitnami report server

  6. this time while installing the report server software will not find any apache tomcat on your local in other words it will refer to the tomcat “C:\Bitnami\reportserver-3.0.2-7\apache-tomcat” folder.

  7. After successful installation, you will be able to run Bitnami report server : http://127.0.0.1/reportserver/

I have a suggestion to Bitnami Report server software - When you already are providing apache tomcat, why do you rely on tomcat server that is already installed?

Please do not check path entries of tomcat and rely on your own tomcat version 9 that comes with the application.

Hi @r.rai,

Please note that we set the CATALINA_HOME directive when installing and running tomcat as our installers don’t use the system’s services when installing or running the application. You can check the different installation scripts of Tomcat inside the apache-tomcat/scripts folder and see how we install the service.

Regards,
Jota