Apache Configuration Errors

Keywords: WordPress - Google Cloud Platform - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: 2535d5c8-44a9-293e-f5f1-87f6c80c5b21

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Connectivity: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
A high number of incoming requests originate from one or more unique IP
addresses, Syntax error in Apache configuration.

Hi @socialgypro,

It seems you archived/deleted the Let’s Encrypt certificates and that’s why Apache can’t use the files. Can you try to recover the archived ones and restart Apache to use them?

sudo cp /opt/bitnami/archives/1631273455.osama4855.me.crt /opt/bitnami/letsencrypt/certificates/osama4855.me.crt
sudo cp /opt/bitnami/archives/1631273455.osama4855.me.key /opt/bitnami/letsencrypt/certificates/osama4855.me.key
sudo /opt/bitnami/ctlscript.sh restart apache

Happy to help!


Was my answer helpful? Click on :heart:

Hi Jota

Thanks for your support, Done but I have another issue now … How to make sure that Auto Renewal SSL Certificate is working with my websites domains or not or working only for 90 days as usual?

My domains is:

osama4855.me
socialgypro.com

Really appreciate your efforts.

Hi @socialgypro,

You can get the renewal command from the crontab configuration

crontab -l

Just run that command adding the --days 90 parameter

sudo /opt/bitnami/letsencrypt/lego --path /opt/bitnami/letsencrypt --email="socialgypro@gmail.com" --http --http-timeout 30 --http.webroot /opt/bitnami/apps/letsencrypt --domains=osama4855.me renew --days 90 && sudo /opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf -k graceful

Happy to help!


Was my answer helpful? Click on :heart:

You mean this command will makes Auto Renewal for SSL Certificate every 90 days?

No, this command is just for testing purposes. It will renew the certificate now.

The autorenewal process is configured as a cron job

crontab -l

it is not working, kindly check this photo …

Hi @socialgypro,

You always need to use the “bitnami” user when running commands in the command line. Please change the user using this command

sudo su bitnami

and then run the crontab command

crontab -l

kindly check this photo …

Hi @socialgypro,

I confirmed that the information was correct when checking the Bitnami Diagnostic Tool information and I explained how you could verify it :slight_smile:

That cron job will try to renew the certificate every night at midnight.

Happy to help!


Was my answer helpful? Click on :heart: