Apach, Resources & Permissions Errors using the diagnostic tool

Keywords: WordPress - AWS - Technical issue - Application configuration

bndiagnostic ID: 6d96326f-c130-4b1d-e674-ec4c68fce155

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
Hi Folks :slight_smile:

I consider myself a self-taught beginner as a developer so bear with me.

  1. The Apache Error seems to be caused by a Plugin however I am unsure and therefore contacting you to be sure.

  2. Increase Memory - I tried to following this guide Increase the available memory but it responded with file permission issue and I don’t seem to have access via FTP and I don’t know how to change the root file permissions on the stack using Terminal.

Error Reports follows.

Thanks,

Justin.

[Apache]

Found recent error or warning messages in the Apache error log.

[Mon May 09 18:29:44.128118 2022] [proxy_fcgi:error] [pid 26402:tid 
140683079816960] [client **ip_address**:51085] AH01071: Got error 'PHP message: 
PHP Notice: Unknown: file created in the system's temporary directory in Unknown 
on line 0', referer: https://partycaribbean.com/wp-admin/upload.php
 [Mon May 09 18:44:54.913336 2022] [proxy_fcgi:error] [pid 26401:tid 
Press [Enter] to continue:
140682735716096] [client **ip_address**:53504] AH01071: Got error 'PHP message: 
PHP Notice: register_rest_route was called <strong>incorrectly</strong>. The 
REST API route definition for <code>appp/v2/in-app-purchase-register</code> is 
missing the required <code>permission_callback</code> argument. For REST API 
routes that are intended to be public, use <code>__return_true</code> as the 
permission callback. Please see <a href="ht [Mon May 09 18:45:05.522740 2022] 
[proxy_fcgi:error] [pid 26415:tid 140682618349312] [client **ip_address**:53508] 
AH01071: Got error 'PHP message: PHP Notice: register_rest_route was called 
<strong>incorrectly</strong>. The REST API route definition for 
<code>appp/v2/in-app-purchase-register</code> is missing the required 
<code>permission_callback</code> argument. For REST API routes that are intended 
to be public, use <code>__return_true</code> as the permission callback. Please 
see <a href="ht

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/

[Resources]

Your instance has little available RAM memory.

Press [Enter] to continue:
 total used free shared buff/cache available Mem: 3946 2793 157 146 995 730 
Swap: 0 0 0

You could try to increase your instance’s memory. Please check your cloud
provider’s documentation for more information.

You can also enable swap memory to improve performance.

https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-m
emory-linux/

===== End of bndiagnostic tool output =====

Press [Enter] to continue:
The diagnostic bundle was uploaded successfully to the Bitnami servers. Please copy the fol
lowing code:

6d96326f-c130-4b1d-e674-ec4c68fce155

bitnami@ip-172-26-9-3:~$ free -m
total used free shared buff/cache available
Mem: 3946 2439 626 146 880 1085
Swap: 0 0 0
bitnami@ip-172-26-9-3:~$

bitnami@ip-172-26-9-3:~$ free -m
total used free shared buff/cache available
Mem: 3946 2424 113 146 1409 1101
Swap: 0 0 0
bitnami@ip-172-26-9-3:~$ sudo dd if=/dev/zero of=/mnt/swap.0 bs=1024 count=1048576
1048576+0 records in
1048576+0 records out
1073741824 bytes (1.1 GB, 1.0 GiB) copied, 16.3421 s, 65.7 MB/s
bitnami@ip-172-26-9-3:~$ free -m
total used free shared buff/cache available
Mem: 3946 2417 113 146 1415 1107
Swap: 0 0 0
bitnami@ip-172-26-9-3:~$ sudo mkswap /mnt/swap.0
mkswap: /mnt/swap.0: insecure permissions 0644, 0600 suggested.
Setting up swapspace version 1, size = 1024 MiB (1073737728 bytes)
no label, UUID=834a118c-40a9-4f49-88b0-70c2c484cca4
bitnami@ip-172-26-9-3:~$

UPDATE

The image below is the current instance so I am unsure as to why I am having RAM memory issues.

Hi @partycaribbean,

I can see you have this error in the Apache’s log and I suggest you contact WordPress to get more information.

[Mon May 09 18:45:05.522740 2022] [proxy_fcgi:error] [pid 26415:tid 140682618349312] [client 82.12.128.75:53508] AH01071: Got error 'PHP message: PHP Notice:  register_rest_route was called <strong>incorrectly</strong>. The REST API      route definition for <code>appp/v2/in-app-purchase-register</code> is missing the required <code>permission_callback</code> argument.

You have a 4GB RAM instance and that should be enough. The tool found that it has little free RAM memory but taking a second look at that info it doesn’t seem to be a problem for you.