All new WordPress deployments on Google Cloud have issue with finding directory that contains a Bitnami installation

Type: Bitnami Support Tool

Description:
Hi, I’m web developer who deploys new Bitnami WordPress stacks many times monthly on Google Cloud but I’ve tried 4 times today to deploy and each time there is an error where when you shell into the site you cannot run Bitnami commands because it always reports there is no directory with a Bitnami installation. It’s version 5.8.2-30 that has the problem. Hence, I cannot run the Bitnami support tool, nor can I run the bncert-tool to deploy HTTPS etc. I’ve tried numerous times to tell the prompt where the Bitnami install is located but it fails to recognize this. After trying new deployments 4 times now, it’s clear there is some issue with 5.8.2-30.

1 Like

I came here to submit this issue. Attempted deployment six times in GCP. Exact same issue.

Hello @atlanta,

We are working on fixing this issue. Could please add this code to /opt/bitnami/properties.ini file?

installdir=/opt/bitnami

Regards

I am super new to building website. Can you let me know how to add the code to the file?

After entering “/opt/bitnami/properties.ini” in the SSH, it replies
-bash: /opt/bitnami/properties.ini: Permission denied

Hi @wongyanyan,

You need to use a command line editor to edit that file

sudo nano /opt/bitnami/properties.ini

As this is already fixed in the tool, you can also download the latest version and run it

cd /tmp
wget -O bncert-linux-x64.run https://downloads.bitnami.com/files/bncert/latest/bncert-linux-x64.run
sudo mkdir /opt/bitnami/bncert
sudo mv bncert-linux-x64.run /opt/bitnami/bncert/
sudo chmod +x /opt/bitnami/bncert/bncert-linux-x64.run
sudo ln -s /opt/bitnami/bncert/bncert-linux-x64.run /opt/bitnami/bncert-tool

https://docs.bitnami.com/general/how-to/understand-bncert/

Thanks a lot~ The problem resolved.