Akeneo memory usage

Keywords: Akeneo - AWS - Technical issue - Other
bnsupport ID: 3001d5f8-aecb-ed75-8a38-a5afd2bba29f
Description:
We have quite a few manufacturers where their data file is 20,000 or more products. We setup Akeneo CE in AWS to evaluate functionality and consistently run into a memory usage issue. When loading larger datasets, the import will race up to about to 10,000-12,000 products and slow right down. At this slow down point, memory usage starts to climb until the PHP memory usage maxs out. Is this expected behavior or is there a configuration change we can make?

Hi @jchapman,

I’m afraid your question exceeds the scope of this community, which is mainly for solving issues related to the Bitnami configuration of the application. Could you ask in a forum that specialises in the application?

Regards,
Michiel

Hi Michiel,
I thought I’d start here in case was the Bitnami configuration of the application. Are you saying this is strictly an Akeneo issue?

Thanks!

-John

Hi @jchapman,

My apologies. It turns out we have a guide to to modify the memory limit for Akeneo. :smile: Can you check it:

https://docs.bitnami.com/aws/apps/akeneo/administration/increase-memory-limit/

Regards,
Michiel

Hi @michiel,
I took a look at that and I still have what appears to be a memory leak issue. Increasing the memory limit just delays when the job ultimately fails. It appears everything is running in production which is what I want so the profiler isn’t running like it would in dev. Is there something in the web interface that might be running in dev?

Hi @jchapman,

That should not be the case. On your side did you run any pim commands without setting --env=prod? Could you also ask in the Akeneo community? They might be able to help you better with this issue there.

Regards,
Michiel

Hi @michiel,
I had been running everything through the web interface but tried running the import job via CLI ensuring --env=prod. That was mildly better. From the Bitnami perspective, if increasing memory via the link you provided has no change in behavior, is there anything else configuration-wise I can check? If not it sounds like this might be something specific Akeneo.

Hi @jchapman,

Thanks for letting us know. If you have tried with the PHP memory limits without success, I think you may need to ask the Akeneo community for further help with this question.

Regards,
Gonzalo

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.