Akeneo is not running - c7b15705-57c0-4911-2100-f450faab671e

Keywords: Akeneo - Google Cloud Platform - Technical issue - Other
bnsupport ID: c7b15705-57c0-4911-2100-f450faab671e
Description:
Akeneo failed saving product data. An error notification appears when we try to save changes. It seems that changes are saved in cache but not in database because we can see it in product page. Any change was made in the server in a couple of weeks before the appearance of the problem. After clearing the Akeneo cache (https://docs.bitnami.com/aws/apps/akeneo/administration/clear-cache/) Akeneo stopped working. We received a 500 HTTP error when we try to enter to Akeneo with a browser. In the server all services are running but akeneo.

We executed the Bitnami support tool. The generated code is c7b15705-57c0-4911-2100-f450faab671e

Thank you in advance.

Hi @Chris_Limbic,

I see the next error in your Apache logs

[Mon Feb 01 11:58:39.709759 2021] [proxy_fcgi:error] [pid 16150:tid 140670144526080] [client 5.189.143.107:46762] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught RuntimeException: Unable to write in the "cache" directory (/opt/bitnami/apps/akeneo/htdocs/var/cache/prod). in /opt/bitnami/apps/akeneo/htdocs/vendor/symfony/http-kernel/Kernel.php:694\nStack trace:\n#0 /opt/bitnami/apps/akeneo/htdocs/vendor/symfony/http-kernel/Kernel.php(598): Symfony\\Component\\HttpKernel\\Kernel->buildContainer()\n#1 /opt/bitnami/apps/akeneo/htdocs/vendor/symfony/http-kernel/Kernel.php(136): Symfony\\Component\\HttpKernel\\Kernel->initializeContainer()\n#2 /opt/bitnami/apps/akeneo/htdocs/vendor/symfony/http-kernel/Kernel.php(196): Symfony\\Component\\HttpKernel\\Kernel->boot()\n#3 /opt/bitnami/apps/akeneo/htdocs/public/index.php(20): Symfony\\Component\\HttpKernel\\Kernel->handle(Object(Symfony\\Component\\HttpFoundation\\Request))\n#4 {main}\n  thrown in /opt/bitnami/apps/akeneo/htdocs/vendor/symfony/http-kernel/Kernel.php on line 694'

It looks like there are some permission issues on your server. Can you tell us which command you used to clean the Akeneo’s cache?

Can you run the next command to update the permissions of the cache directory?

sudo chown -R daemon:daemon /opt/bitnami/apps/akeneo/htdocs/var/cache

After that, please restart the services again

1 Like

Hi @gongomgra,

It works. All the problems were solved. Thank you so much.

For your interest, I used these commands to clean the Akeneo’s cache:

cd /opt/bitnami/apps/akeneo/htdocs
php bin/console cache:clear --no-warmup --env=prod
sudo chmod -R 775 var/cache

Salud,
Chris

EDIT: @gongomgra commands highlight

Hi @Chris_Limbic,

Thanks for the info. I’m glad it fixed your issue. I don’t know why the cache folder was owned by root user, did you run any of those commands as root or with sudo apart from the last one?

Hi @gongomgra,

I don’t think so but I cannot remember it exactly. I think I copy and paste the commands from your tutorial but that I found the commands in another source (with sudo in the clearing cache command) is a possibility. Thank you for your help and congrats for your great product :wink:

Hi @Chris_Limbic,

Thanks for your kind words! We are glad you could fix your issue :slight_smile:

We will close this thread as solved. Please do not hesitate to open a new thread with any other questions you may have.

Regards,
Gonzalo