Akeneo 3.2.9 to 5.0.5 upgrade steps

Keywords: Akeneo - Virtual Machines - Technical issue - Upgrade
I cannot seem to find this information anywhere. i have the akeneo stack on 3.2.9 and trying to upgrade to akeneo 5.0.5 stack. I have the new vm running and a mysqldump of the old vm. i cannot find any information on what is the best way to migrate the data to the new vm. importing the mysql just breaks akeneo.

Hi @dsage,

Did you follow the steps described in this guide?



I did not. I do not see how that would get me from 3.2.9 to 5.0.5. I have 2 VMs right now, the original on 3.2.9 and the new on 5.0.5. I attempted to get a mysql dump from 3.2.9 and imported it into 5.0.5 and tried to run the akeneo data migration processes. this did not work and broke akeneo, so rolled it back to earlier snapshot.

Has anyone upgraded akeneo through bitnami? I don’t believe people would just start fresh. the backup and restore link above does not work for an upgrade to a new version. that would backup the old version and restore the old version. unless I am missing something.

Hello @dsage,

I would try to upgrade it per major version. First, upgrade Akeneo 3.2 to Akeneo 4.

You can download version 4 from the link below:

Then, try to upgrade Akeneo 4 to version 5:


thank you, i’ll try that. however the v4 link is not working for me.

Sorry. I have edited the link, there was a typo.

i have the v4 VM up, imported my sqldump, and ran the pim check requirement step. it stated i need aspell, so I installed that and pass the check requirement step. did the prepare the front step as root, got an error on final step stating webpack: permission denied. attempted the migrate data step and it is saying it could not find any migrations to execute.

Hello @dsage,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

ran it on the v4 VM, code is 182d00d9-44cf-b1cf-77fa-70f5297d4115

did the support tool upload the needed information?

Hi @dsage,

We are still working on creating a similar environment to yours so that we can try to reproduce the issue. I hope we can give you some hints to help with your problem.

Let us know if you have any updates on your end.

Thanks for your patience,
Andrés Bono.

sounds good. thank you. best I can do is give you the steps that I performed.

My original stack is bitnami-akeneo- We have about 300k products in the system across a hundred or so attributes. I ran a mysqldump on the bitnami_akeneo database and moved the sql file over to the new stack.

The new stack is bitnami-akeneo-4.0.83-0-linux-debian-10-x86_64. First I imported the sql into bitnami_akeneo. I then followed the migrate_pim link from akeneo you suggested. Since the code was already updated in the stack, I skipped down to the data migration steps. In one of the checks, it stated I was missing Aspell, so I apt-get installed that. after that i ran into problems.

Hi @dsage,

We are now reproducing your issues but we still don’t know a clear path to do the migration.

Any updates on your side?

Best regards,
Andrés Bono.

none. i have not figured it out either.

where you able to do a migration?

Hi @dsage,

I’m afraid that I couldn’t make any further progress so far.

Thanks for your patience,
Andrés Bono.

Hi @dsage,

Just for your reference, there is a very similar case that you can take a look at: https://community.bitnami.com/t/how-to-upgrade-akeneo-pim-on-bitnami-vm

As you can see, the approach followed there is different as it is also replacing the new /opt/bitnami/apps/akeneo with the old one.

Best regards,
Andrés Bono.

this method worked. once I set my values in the .env file, the upgrade went smooth. i had to reset file permissions for the cache at the end as well. Thank you.

1 Like