A few details regarding PostgreSQL 12.1.0-0 VMDK

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?: PostgreSQL 12.1.0-0

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX): VMDK

  • Have you installed any plugin or modified any configuration file?: NO

  • Describe here your question/suggestion/issue (expected and actual results):

Before starting up the VM, I had found I was not able to configure the keyboard layout as specified in https://docs.bitnami.com/virtual-machine/faq/configuration/configure-keyboard/ . The problem was the packages keyboard-configuration and console-setup . So I had to install them with:

sudo apt install keyboard-configuration
sudo apt install console-setup

The other problem I found is I was not able to connect locally to the database because neither I could not log in as postgres user nor impersonate as it with sudo:

bitnami@debian:~$ sudo -i -u postgres
sudo: unable to change directory to /home/postgres: No such file or directory
sudo: unable to execute /bin/sh: No such file or directory

I hope it helps to improve the VM

Hi @rubendopico,

Thanks for the feedback. We will take a look at it and do the necessary changes.

About the connection to the database, did you try with the following command:

psql -h 127.0.0.1 -U postgres

Which is the exact error that you get?

That worked like a charm.

Thanks!

Hi @rubendopico,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.