502 Bad Gateway Error on the new instance

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Other
bnsupport ID: f3634f94-1d8c-15c8-11eb-b8125bf7a17a
Description:
Hello,

We recently created a new instance which is supposed to be the new version of an already existing WP Site. We were also able to export the old data from the old site and import it to this new instance.

But it’s been like almost 10-12 hours. Only sometimes the WP-ADMIN will open, And the rest of the times we get “502 Bad Gateway” error (https://prnt.sc/137m9r3)

Also, I was not able to successfully run bnsupport tool - It is also showing some errors: https://prnt.sc/137mhqn

2021/05/21 07:30:44 [error] 3757#3757: *142 FastCGI sent in stderr: "y SELECT 
name, val, autoload FROM wp_wfConfig WHERE name = 'timeoffset_wf' made by 
require_once('wp-load.php'), require_once('/bitnami/wordpress/wp-config.php'), 
require_once('wp-settings.php'), do_action('plugins_loaded'), 
WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, 
wfConfig::getPHP message: WordPress database error Table 
'bitnami_wordpress.wp_wfHits' doesn't exist for query SELECT MAX(attackLogTime) 
Press [Enter] to continue:
FROM wp_wfHits made by require_once('wp-load.php'), 
require_once('/bitnami/wordpress/wp-config.php'), 
require_once('wp-settings.php'), do_action('plugins_loaded'), 
WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstActionPHP 
message: WordPress database error Table 'bitnami_wordpress.wp_wfConfig' doesn't 
exist for query SELECT name, val, autoload FROM wp_wfConfig WHERE name = 
'firewallEnabled' made by require_once('wp-load.php'), 
require_once('/bitnami/wordpress/wp-config.php'), 
require_once('wp-settings.php'), do_action('plugins_loaded'), 
WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, 
wfConfig::getPHP message: WordPress database error Table 
'bitnami_wordpress.wp_wfConfig' doesn't exist for query SELECT name, val, 
autoload FROM wp_wfConfig WHERE name = 'other_hideWPVersion' made by 
require_once('wp-load.php'), require_once('/bitnami/wordpress/wp-config.php'), 
require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, 
WP_Hook->apply_filters, wordfence::initAction, wfConfig::getPHP message: 
WordPress database error Table 'bitnami_wordpress.wp_wfConfig' doesn't exist for 
query SELECT name, val, autoload FROM wp_wfConfig WHERE name = 
'liveTrafficEnabled' made by wfLog->logHit, wfConfig::liveTrafficEnabled, 
wfConfig::getPHP message: WordPress database error Table 
'bitnami_wordpress.wp_wfBlocks7' doesn't exist for query SELECT *, CASE 
 2021/05/21 07:30:44 [error] 3757#3757: *142 FastCGI sent in stderr: "d FROM 
wp_wfConfig WHERE name = 'cbl_bypassRedirURL' made by 
Press [Enter] to continue:
wfWAFIPBlocksController::synchronizeConfigSettings, wfConfig::getPHP message: 
WordPress database error Table 'bitnami_wordpress.wp_wfConfig' doesn't exist for 
query SELECT name, val, autoload FROM wp_wfConfig WHERE name = 
'cbl_bypassRedirDest' made by 
wfWAFIPBlocksController::synchronizeConfigSettings, wfConfig::getPHP message: 
WordPress database error Table 'bitnami_wordpress.wp_wfConfig' doesn't exist for 
query SELECT name, val, autoload FROM wp_wfConfig WHERE name = 
'cbl_bypassViewURL' made by wfWAFIPBlocksController::synchronizeConfigSettings, 
wfConfig::getPHP message: WordPress database error Table 
'bitnami_wordpress.wp_wfConfig' doesn't exist for query SELECT name, val, 
autoload FROM wp_wfConfig WHERE name = 'cbl_redirURL' made by 
wfWAFIPBlocksController::synchronizeConfigSettings, wfConfig::getPHP message: 
WordPress database error Table 'bitnami_wordpress.wp_wfConfig' doesn't exist for 
query SELECT name, val, autoload FROM wp_wfConfig WHERE name = 'cbl_cookieVal' 
made by wfWAFIPBlocksController::synchronizeConfigSettings, 
wfBlock::countryBlockingBypassCookieValue, wfConfig::getPHP message: WordPress 
database error Table 'bitnami_wordpress.wp_wfConfig' doesn't exist for query 
INSERT INTO wp_wfConfig (name, val, autoload) values ('cbl_cookieVal', 
'60a761a4425dd', 'yes') ON DUPLICATE KEY UPDATE val = '60a761a4425dd', autoload 
= 'yes' made by wfWAFIPBlocksController::synchronizeConfigSettings, 
wfBlock::countryBlockingBypassCookieValue, wfConfig::setPHP message: WordPress 
database error Table 'bitnami_wordpress.wp_wfConfig' doesn't exist for query 
SELECT name, val, autoload FROM wp_wfConfig WHERE name = 'blockedTime' made by 
Press [Enter] to continue:
wfWAFIPBlocksController::synchronizeConfigSettings, wfConfig::getPHP message: 
WordPress database error Table 'bitnami_wordpress.wp_wfBlocks7' doesn't exist 
for query SELECT *, CASE 
 2021/05/21 07:30:44 [error] 3757#3757: *142 FastCGI sent in stderr: 
"ess.wp_wfConfig' doesn't exist for query SELECT name, val, autoload FROM 
wp_wfConfig WHERE name = 'disableWAFIPBlocking' made by 
wfWAFIPBlocksController::synchronizeConfigSettings, wfConfig::get" while reading 
response header from upstream, client: 106.217.51.164, server: _, request: "POST 
/wp-admin/admin-ajax.php HTTP/1.1", upstream: 
"fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "oormaniangadi.com", 
referrer: "https://oormaniangadi.com/wp-admin/"

It also said:
The files listed below are bigger than 10MB and have not been included, please notify the support agent. /opt/bitnami/nginx/logs/error.log

Can somebody please help?

Hi @vgnavada

Thanks for using Bitnami WordPress + NGINX + SSL!

Also, I was not able to successfully run bnsupport tool - It is also showing some errors:

We have implemented some changes in order for the tool to show the errors that have been identified in your instance. Hence, the errors you are seeing do not correspond to bnsupport itself, but to your instance :slightly_smiling_face:

I have been reviewing the output and it seems that this might be related to the database not being properly set up. The following trace in your log states that some tables could not be found:

... 
database error Table 'bitnami_wordpress.wp_wfConfig' doesn't exist for query ...
...

Please make sure that the database was correctly imported. If you have several backup files, ensure that you have used the latest one.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hello @jcarmona
Could not properly understand what exactly to do. So we deleted the entire instance and presently using the old instance itself. Any ways, Thanks for the reply :slight_smile:

My pleasure!

Glad to see you were able to solve your issue! If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.