500 Internal Server Error after restoring Akeneo Backup

Keywords: Akeneo - Virtual Machines - Technical issue - Other
bnsupport ID: c3ed0812-5830-9479-09d3-2cb6205da870
Description:
Akeneo works like a charm when I first run it in VMware Fusion. However, I’d like to make sure that I can backup the data safely before deploying Akeneo.

To test this, I used the same Akeneo image to setup two VM instances, VM 1 and VM 2. I followed the instructions this page. to attempt a backup.

My procedures as as follows:

  1. Stop the server in VM 1
  2. Create a tar.gz backup of the /bitnami directory
  3. Copy the file from VM 1 to my host machine using scp
  4. Copy the file from my host machine to VM 2
  5. Stop the server in VM 2
  6. Decompress the tar.gz backup
  7. Start the server in VM 2

When I access Akeneo after completing step 7, I am greeted with the 500 Internal Server Error.

I’d be grateful if anyone can shed some light on what the issue might be.

Hi @itsrocky,

I found this error in the Apache’s log

https://docs.bitnami.com/virtual-machine/apps/akeneo/troubleshooting/debug-errors-apache/

[Wed Apr 28 09:55:53.147227 2021] [proxy_fcgi:error] [pid 4602:tid 140599264597760] [client 192.168.1.12:50621] AH01071: Got error 'PHP message: PHP Warning:  session_start(): Failed to initialize storage module: user (path: ) in /opt/bitnami/akeneo/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php on line 156PHP message: PHP Warning:  session_start(): Failed to initialize storage module: user (path: ) in /opt/bitnami/akeneo/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php on line 156PHP message: PHP Warning:  session_start(): Failed to initialize storage module: user (path: ) in /opt/bitnami/akeneo/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php on line 156'

Please note that the guide also explains how to backup the /opt/bitnami folder. Maybe there is some information missing and that’s why the backup restore is failing in the VM 2. Can you try to recover the /opt/bitnami information in the second VM too?

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.