403 error on custom domain vhost in multisite network

Keywords: WordPress Multisite - AWS - Technical issue - Permissions

bnsupport ID: 2922e02a-0d22-004d-b9cf-75e5a33591a5

bndiagnostic output:

? Apache: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I have migrate a WP Multisite instance from on older Lightsail instance to a new instance, and have reconfigured all of the required settings/configs to get everything up and running.

Am able to access the main site and networked sites on sub-domains with no issues, e.g:

Main domain: https://creativecruising.com.au/
Sub domain: https://italktravel-castlehill.creativecruising.com.au/

But I have three network sites on custom domains, e.g. https://cruises.hopperound.com.au/ that I can access and the correct SSL cert is applied, but are returning 403 errors.

I’ve searched around in the vhosts files and other conf files, trying to find where the issue might be, but I’m either blind or very tired!?

Can you help point me to a solution please.

Many thanks

Hi @Lafinboy,

Can you check if you followed the same steps as described in this guide:

https://docs.bitnami.com/ibm/apps/wordpress-multisite/configuration/configure-wordpress-multisite/#add-several-wordpress-multisite-blogs-with-different-domains

Regards.
Michiel

Hi Michiel

Yes the network has been set up and running for over 2 years on another Lightsail instance.

The issue isn’t with the Wordpress side of things, there is some config on the new server that is blocking access to the vhost domains.

The old Lightsail instance was Ubuntu, the new instance is Debian, with the latest version of Bitnami Wordpress Mulitsite.

There are differences in the structure of the two servers, the various configs that are available, etc, and I can’t find where the issue is now.

Hi @Lafinboy,

Thanks for your message. I checked the vhost file for the cruises.hopperound.com.au website and I think I found an issue on it. You defined a Directory section for the /opt/bitnami/apache/htdocs folder, but the WordPress application is installed at /opt/bitnami/wordpress instead. Can you replace the next section in your vhost file

  <Directory "/opt/bitnami/apache/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted

  </Directory>

with this one and then restart Apache?

  <Directory "/opt/bitnami/wordpress">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
  </Directory>

You can use the next command to restart Apache

sudo /opt/bitnami/ctlscript.sh restart apache

If you continue having issues after doing these changes, please run the bnsupport tool again and send us the new code so we can check the updated logs and config.

OMG! Thank you that’s the fix.

I’ve been staring at these files for so long I was blind to that.

Massive thanks for your help - on point as always :slightly_smiling_face:

This ticket is now resolved

Hi @Lafinboy,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.