2 VMs have the same IP Address

Keywords: PostgreSQL - Virtual Machines - Technical issue - Other
Description:
I have my host machine with Windows 10, there I run 2 Debian VMs: Redis and PostgreSQL.
But when I execute

ifconfig
I see that both machines have the same IP address: 192.168.0.86.

How I can fix it? Or may be how each VM can query IP in my domain DHCP server?

By the way, I have asked the same question on VirtualBox support forum and attached my VM logs.
That is link
https://forums.virtualbox.org/viewtopic.php?f=6&t=86648&sid=8dc59ad52765644272ec216f846d3e89
and there is a comment:

After some more comparative analysis (not between your two VMs), here are some interesting things that I found:
00:00:01.858220 Guest OS type: ‘Other_64’
00:00:01.860906 File system of ‘E:\VMs\bitnami-redis-4.0.6-0-r04-linux-debian-9-x86_64-disk1.vmdk’ is ntfs
That’s a really weird template choice for a Debian. I mean, the “Debian (64 bit)” option is right there…

00:00:02.054505 RamSize = 0x0000000020000000 (536 870 912, 512 MB)
That’s rather small for a 64-bit Debian. Most probably because of the wrong template? Not really, because the default for “Other 64” is 64 MB, not 512. So somebody messed with, just not enough…

00:00:02.054616 [/Devices/lsilogicscsi/0/Config/]
Speaking of messing (up). LSILogic? Why, oh, why? Because it can?

I think you should talk to the Bitnami people…

What I have found in VirtualBox is that if you clone the machine, it has the same MAC address.
Wherefore, it gets assigned the same IP.
By changing the MAC, I got a different IP on my clone.
I hope this helps.

Hi @winpook,

Could you check if both Redis and PostgreSQL have the same MAC address?
If they have the same MAC, they will get the same IP from the DHCP service (they both are the same machine for this service).

In case this is happening, you can change the MAC address from VirtualBox in the hardware network section. If you are using another virtualization software, it should have a way to configure this, since MAC is faked by this software.

I hope it helps!
Joseda Rios

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.