#1 By: Greg, August 15th, 2011 17:25
When I try a rake db:migrate, that fails:
WARNING: This version of mysql2 (0.3.6) doesn't ship with the ActiveRecord adapter bundled anymore as it's now part of Rails 3.1
WARNING: Please use the 0.2.x releases if you plan on using it in Rails <= 3.0.x
Am I doing something wrong, or does the bitnami rubystack come with incompatible versions
of rails and mysql2?
Should I upgrade to rails 3.1 or downgrade mysql to 0.2.x?
#2 By: kaysa, August 16th, 2011 04:25
BitNami RubyStackDev includes rails 3.0 and mysql gem 2.8.1 which are compatible. It doesn't include mysql2 gem.
In this question you created a new project using mysql2 in the Gemfile and with
bundle install the mysql2(0.3.6) gem was installed. If you execute
'gem list' you will see the both mysql and mysql2 gems installed.
Currently Rails 3.1 is not the final stable version (the available version is a release candidate). If you want to use mysql2 gem with Rails 3.0 you can use the following in the Gemfile of your project:
gem 'mysql2', '< 0.3.0'
'bundle install' you will get mysql2 0.2.11 (currently the latest 0.2.x version) installed.
#3 By: Greg, August 17th, 2011 01:04
Thanks very much for the help and the clarification! I am now running happily.
I really appreciate your help.